Skip Navigation Links | |
Exit Print View | |
man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library |
- administer shared objects based on storage URIs
/usr/sbin/suriadm command [options] [operands]
/usr/sbin/suriadm parse [-H] [-o p,p,...] URI /usr/sbin/suriadm map [-H] [-o p,p,...] URI /usr/sbin/suriadm lookup-mapping [-H] [-o p,p,...] URI /usr/sbin/suriadm unmap URI /usr/sbin/suriadm lookup-mapping [-t uri-type] [-H] [-o p,p,...] device-name
The suriadm command line administration tool allows system users to manage storage objects via storage URIs. The command allows to parse, map, unmap, query the state of mappings and look up storage URIs.
Supported storage URIs are defined in suri(5) manual page.
The following subcommands are supported:
Parses a given URI and displays a default list of properties. With -H, a header is omitted from the output. With -o, only properties from the list provided are displayed. The -o option implies output on one line, with property values separated by tabs, meant to be further processed by another command.
Allowed property names for the -o option are: uri-type, uri, path, mapped-dev, initiator, target, luname, hostname, and port.
Parses a storage URI, configures the storage subsystem if necessary to instantiate a device corresponding to the URI provided, and displays the device path. If the device is already instantiated, the map operation only looks up the device path.
For an iSCSI URI, this subcommand will add a send-targets discovery address(es) a hostname resolves to if a URI authority section is present.
For logical unit and dev URI types, this subcommand has no effect on system configuration.
Parses a URI and looks up an existing mapping between a storage URI and the shared storage object represented by a local system device path. Default list of properties is displayed. Options -H and -o have the same meaning as for the parse subcommand.
Parses and unmaps an object presumably mapped before. Does not display any properties or accept any options.
For an iSCSI URI, this subcommand removes discovery addresses to which a hostname from a URI authority section resolves, if present.
For logical unit and dev URI types, this subcommand has no effect on system configuration.
Looks up and displays URIs based on a local system device path. Allowed URI types for -t are dev, lu, and iscsi. If the -t option is not specified, the output consists of all URIs that match the device path for any URI type.
Example 1 Parsing a URI and Displaying Properties
The following command parses and iSCSI URI and displays a default list of properties.
$ suriadm parse iscsi://10.0.0.1:3260/luname.naa.0123456789abcdef PROPERTY VALUE uri-type iscsi hostname 10.0.0.1 port 3260 luname naa.0123456789abcdef
Example 2 Mapping an iSCSI URI and Displaying a Device Name
The following command maps an iSCSI URI and displays a mapped local system device name. The effect of this command is to automatically add a send-targets discovery address if one is not already present.
$ suriadm suriadm map iscsi://127.0.0.1/luname.naa.\ 600144F0F4977D4000004F7EC8F00001 PROPERTY VALUE mapped-dev /dev/dsk/c0t600144F0F4977D4000004F7EC8F00001d0s2
Example 3 Looking Up Mapping
The following command looks up an existing iSCSI mapping.
$ suriadm lookup-mapping iscsi://127.0.0.1/\ luname.naa.600144F0F4977D4000004F7EC8F00001 PROPERTY VALUE mapped-dev /dev/dsk/c0t600144F0F4977D4000004F7EC8F00001d0s2
Example 4 Parsing a Logical Unit URI
The following command parses an initiator/target/luname logical unit URI.
$ suriadm parse lu:initiator.naa.2101001b32ae7ab5,\ target.naa.2100001d38089fb0,luname.naa.500000e012942880 PROPERTY VALUE uri-type lu luname naa.500000e012942880 initiator naa.2101001b32ae7ab5 target naa.2100001d38089fb0
Example 5 Mapping a Logical Unit URI, Looking Up URIs
The following command sequence maps a logical unit URI, then looks up the matched logical unit URIs based on a found device name.
$ suriadm map lu:luname.naa.5000c5000288fa25 PROPERTY VALUE mapped-path /dev/dsk/c7t26d0s2 $ suriadm lookup-uri -t lu /dev/dsk/c7t26d0s2 lu:luname.naa.5000c5000288fa25 lu:initiator.naa.500605b000ae7010,target.naa.\ 5001636000019c11,naa.5000c5000288fa25
Example 6 Looking Up Matching URIs
The following command looks up all URIs that match a specific device name without specifying a URI type.
$ suriadm lookup-uri /dev/dsk/c7t26d0s2 lu:luname.naa.5000c5000288fa25 lu:initiator.naa.500605b000ae7010,target.naa.5001636000019c11,\ luname.naa.5000c5000288fa25 dev:dsk/c7t26d0s2
Example 7 Parsing a URI, Displaying Selected Properties
The following command parses a URI and displays only selected properties, all on the same line, separated by tabs, and with no header.
$ suriadm map -Ho uri-type,luname,mapped-path \ lu:luname.naa.5000c5000288fa25 lu naa.5000c5000288fa25 /dev/dsk/c7t26d0s2
Example 8 Looking Up Logical Unit URIs
The following command looks up logical unit URIs for a device accessible by means of multiple paths.
$ suriadm lookup-uri -t lu /dev/dsk/c11t2000001D38089FB0d0 lu:luname.naa.2000001d38089fb0 lu:initiator.naa.2101001b32ae7ab5,target.naa.2100001d38089fb0,luname.\ naa.2000001d38089fb0 lu:initiator.naa.2100001b328e7ab5,target.naa.2200001d38089fb0,luname.\ naa.2000001d38089fb0
Example 9 Trying to Parse Incorrect URI
The following command attempts to parse a syntactically incorrect URI.
$ suriadm parse lu:luname.naa.0123456789 Failed to parse URI "lu:luname.naa.0123456789": GUID part in "luname.naa.GUID" not 16 or 32 character hexadecimal number: "0123456789"
Example 10 Trying to Map LU URI with Inaccessible LU
The following command attempts to map an LU URI with a logical unit name not accessible from the system.
$ suriadm map lu:luname.naa.0123456789abcdef Failed to map URI "lu:luname.naa.0123456789abcdef": No such logical unit "naa.0123456789abcdef" found
Example 11 Looking Up URI for Non-Existent Device Path
The following command attempts to lookup a URI for a non-existent device path.
$ suriadm lookup-uri /dev/dsk/nonexistent Failed to map "/dev/dsk/nonexistent" to URI: No such device: "/dev/dsk/nonexistent"
Command succeeded.
Command failed.
See attributes(5) for descriptions of the following attributes:
|
stmsboot(1M), svcadm(1M), attributes(5), suri(5), scsi_vhci(7D)
Small Computer System Interface-3 (SCSI-3)
When an iSCSI URI is used, the svc:/network/iscsi/initiator service must be enabled, unless a parse operation is being performed. If this service is disabled and an iSCSI URI is being processed, the iSCSI initiator service will be automatically enabled temporarily. The service is never disabled through the suriadm command.