Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library |
- return the sample format for an audio engine
#include <sys/audio/audio_driver.h> int prefix_format(void *state);
pointer to driver supplied soft state
Solaris DDI specific (Solaris DDI)
The audio_engine_format() function is called by the framework to determine the format of the engine.
The audio framework supports the following formats for audio engines:
16-bit signed little endian linear PCM
16-bit signed big endian linear PCM
24-bit signed little endian linear PCM
24-bit signed big endian linear PCM
32-bit signed little endian linear PCM
32-bit signed big endian linear PCM
The 24-bit bit types above store each 24-bit sample in a 32-bit word.
An audio engine may not change the format it uses while it is open.
The audio_engine_format() function returns the audio format of the engine.
This function may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes:
|