Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library |
- return the depth of an audio engine's queue
#include <sys/audio/audio_driver.h> uint_t prefix_qlen(void *state);
pointer to driver supplied soft state
Solaris DDI specific (Solaris DDI)
The audio_engine_qlen() function returns the depth, in frames, of any on-device FIFO. It is used to improve the latency-related calculations in the framework. For most devices the value 0 is appropriate, since they DMA directly from the buffer into the codec.
The audio_engine_qlen() function returns the depth of any hardware FIFO as a count in frames.
This function may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes:
|