Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library |
- return the play-ahead sample count for an audio engine
#include <sys/audio/audio_driver.h> uint_t prefix_playahead(void *state);
pointer to driver supplied soft state.
Solaris DDI specific (Solaris DDI)
The audio_engine_playahead() function returns a driver-supplied hint indicating how many frames the framework should queue up to the device to avoid device underruns. This entry point is optional and NULL may be supplied, in which case the framework will assume a default that is reasonable for most devices.
This entry point is most appropriate for devices with inconsistent scheduling, such as emulated devices or devices backed by user programs. For these devices, this entry point allows the driver to supply a larger value than the normal default.
The audio_engine_playahead() function returns the number of frames the framework should queue for playback.
This function is only called after the device is first opened; the dynamically changing values are not supported.
This function may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes:
|