Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library |
- notification entry point
#include <sys/sockfilter.h> void prefix_notify(sof_handle_t hdl, void *cookie, sof_event_t event, uintptr_t event_data);
per-socket filter handle
per-socket filter-private data
socket event. The following events are possible:
Socket is closing.
A connect operation has finished, and event_data, treated as an uint32_t, indicates the result:
Connect operation was successful.
An error, as described in Intro(2), occurred.
An event has occurred that has impacted the socket's ability to receive and/or send data. event_data, treated as an uint32_t, describes what has been shut down:
The receive side has shut down.
The send side has shut down.
The receive and send sides have shut down.
Flow control has been cleared. event_data, treated as an int32_t, indicate the direction:
Receive side.
Send side.
event specific information
The sofop_notify() entry point is called in response to state changes for the socket. Notifications are purely informational and cannot be modified by the filter.
The sofop_notify() entry point can be called from interrupt context, except when event is SOF_EV_CLOSING, in which case sofop_notify() is guaranteed to be called from kernel or user context.
See attributes(5) for descriptions of the following attributes:
|