Skip Navigation Links | |
Exit Print View | |
man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library |
- get and set HAL device properties
hal-get-property --udi udi --key key [--help] [--verbose] [--version]
hal-set-property --udi udi --key key {--int value | --uint64 value | --string value | --bool value | --strlist-pre value | --strlist-post value | --strlist-rem value | --double value | --remove value} [--help] [--version]
The Hardware Abstraction Layer (HAL) provides a view of the various hardware attached to a system. This view is updated dynamically as hardware configuration changes by means of hotplug or other mechanisms. HAL represents a piece of hardware as a device object. A device object is identified by a unique identifer and carries a set of key/value pairs, referred to as device properties. Some properties are derived from the actual hardware, some are merged from device information files (.fdi files), and some are related to the actual device configuration.
The hal-get-property and hal-set-property commands allow you to get and set properties of hardware that conforms to HAL specifications.
The following options are supported:
Unique device ID.
Key of the property to set.
Set value to an integer. Accepts decimal or hexadecimal value prefixed with 0x or x.
Set value to an integer. Accepts decimal or hexadecimal value prefixed with 0x or x.
Set value to a string.
Set value to a floating point number.
Set value to a boolean, that is, true or false
Prepend a string to a list.
Append a string to a list.
Remove a string from a list.
Indicates that the property should be removed.
Display version and exit.
Display list of options and exit
See attributes(5) for descriptions of the following attributes:
|