Skip Navigation Links | |
Exit Print View | |
man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library |
- Manages automated installations on a network
/usr/sbin/installadm [-h|--help]
installadm help [subcommand]
installadm create-service [-n|--service svcname] [-s|--source source] [-p|--publisher publisher=origin] [-a|--arch architecture] [-d|--imagepath imagepath] [-y|--noprompt] [-t|--aliasof aliasof] [-i|--ip-start start] [-c|--ip-count count] [-b|--boot-args property=value,...] [-B|--bootfile-server server]
installadm set-service -o|--option property=value svcname
installadm update-service [-p|--publisher publisher=origin] [-s|--source FMRI] svcname
installadm rename-service svcname newsvcname
installadm enable svcname
installadm disable svcname
installadm delete-service [-r|--autoremove] [-y|--noprompt] svcname
installadm list [-n|--service svcname] [-c|--client] [-m|--manifest] [-p|--profile]
installadm create-manifest -n|--service svcname -f|--file filename [-m|--manifest manifest] [-c|--criteria criteria=value|list|range... | -C|--criteria-file criteriafile] [-d|--default]
installadm update-manifest -n|--service svcname -f|--file filename [-m|--manifest manifest]
installadm delete-manifest -n|--service svcname -m|--manifest manifest
installadm create-profile -n|--service svcname -f|--file filename... [-p|--profile profile] [-c|--criteria criteria=value|list|range... | -C|--criteria-file criteriafile]
installadm update-profile -n|--service svcname -f|--file filename [-p|--profile profile]
installadm delete-profile -n|--service svcname -p|--profile profile...
installadm export -n|--service svcname -m|--manifest manifest... -p|--profile profile... [-o|--output pathname]
installadm validate -n|--service svcname -P|--profile-file filename... | -p|--profile profile...
installadm set-criteria -n|--service svcname -m|--manifest manifest -p|--profile profile... -c|--criteria criteria=value|list|range... | -C|--criteria-file criteriafile | -a|--append-criteria criteria=value|list|range...
installadm create-client -n|--service svcname [-b|--boot-args property=value,...] -e|--macaddr macaddr
installadm delete-client macaddr
The Automated Installer (AI) is used to automate the installation of the Oracle Solaris OS on one or more SPARC and x86 systems over a network.
The machine topography necessary to employ AI over the network is to have an install server, a DHCP server (this can be the same system as the install server), and the installation clients. On the install server, install services are set up to contain an AI boot image, which is provided to the clients in order for them to boot over the network, input specifications (AI manifests and derived manifests scripts), one of which will be selected for the client, and Service Management Facility (SMF) configuration profiles, zero or more of which will be selected for the client.
The AI boot image content is published as the package install-image/solaris-auto-install, and is installed by the create-service subcommand. The create-service subcommand is also able to accept and unpack an AI ISO file to create the AI boot image.
Install services are created with a default AI manifest, but customized manifests or derived manifests scripts (hereafter called “scripts”) can be added to an install service by using the create-manifest subcommand. See Installing Oracle Solaris 11.1 Systems for information about how to create manifests and derived manifests scripts. The create-manifest subcommand also allows criteria to be specified, which are used to determine which manifest or script should be selected for an installation client. Criteria already associated with a manifest or script can be modified using the set-criteria subcommand.
Manifests can include information such as a target device, partition information, a list of packages, and other parameters. Scripts contain commands that query a running AI client system and build a custom manifest based on the information it finds. When AI is invoked with a script, AI runs that script as its first task, to generate a manifest.
When the client boots, a search is initiated for a manifest or script that matches the client's machine criteria. When a matching manifest or script is found, the client is installed with the Oracle Solaris release according to the specifications in the matching manifest file, or to the specifications in the manifest file derived from the matching script. Each client can use only one manifest or script.
Each service has one default manifest or script. The default is used when the criteria of no other manifest or script matches the system being installed. Any manifest or script can be designated as the default. Any criteria associated with a default manifest or script become inactive and are not considered during manifest or script selection. If a different manifest or script is later made the default, the criteria of the former default manifest or script become active again. Manifests or scripts with no criteria associated with them can only be used as default manifests or scripts. Manifests or scripts without criteria become inactive when a different manifest or script is designated the default.
System configuration profiles are complementary to manifests and scripts in that they also contain specifications for an installation. In particular, profiles are used to specify configuration information such as user name, user password, time zone, host name, and IP address. Profiles can contain variables that are replaced at installation time with appropriate values for the client being installed. In this way, a single profile file can set different configuration parameters on different clients. See the “Examples” section.
System configuration profiles are processed by smf(5) and conform to document format service_bundle(4). See sysconfig(1M) and Chapter 11, Configuring the Client System, in Installing Oracle Solaris 11.1 Systems for more information about system configuration profiles. Each client can use any number of system configuration profiles. A particular SMF property can be specified no more than once for each client system.
If you want a specific client to use a specific install service, you can associate that client with the service by using the create-client subcommand. You can also use create-client to modify an existing client.
The installadm utility can be used to accomplish the following tasks:
Set up install services and aliases
Update the net image of certain install services
Set up installation images
Set up or delete clients
Add, update, or delete manifests and scripts
Specify or modify criteria for a manifest or script
Export manifests and scripts
Add or delete system configuration profiles
Validate profiles
Specify or modify criteria for profiles
Export profiles
Enable or disable install services
List install services
List clients for an install service
List manifests and scripts for an install service
List profiles for an install service
The following properties of the svc:/system/install/server:default SMF service are used to configure the install server.
A list of networks in CIDR format (for example, 192.168.56.0/24) to allow or disallow, depending on how the all_services/exclude_networks property is set.
Use this list of networks to specify which clients this install server serves. By default, the AI install server is configured to serve install clients on all networks that the server is connected to if the server is multihomed.
A boolean value. If true, exclude networks specified by the all_services/networks property from being served by this install server. If false, include networks specified by the all_services/networks property.
Specifies the port that hosts the AI install services web server. By default, the web server is hosted on port 5555.
If you want to use a different port number from the default, customize the port property before you create any install services.
Specifies the default location for images created by the installadm create-service command. Images are located at all_services/default_imagepath_basedir/service_name. The default value of this property is /export/auto_install.
A boolean value. If true, automatically update the local ISC DHCP configuration when client and service configurations are modified in the install server. If false, do not automatically maintain the ISC DHCP configuration.
The installadm command has the following option:
Show the usage help message.
The installadm command has the subcommands listed below. See also the “Examples” section below.
Displays the syntax for the installadm utility.
Displays the syntax for only the specified subcommand.
This subcommand sets up a network boot image (net image) in the specified imagepath directory, and creates an install service that specifies how a client booted from the net image is installed.
The AI boot image content is published as the package install-image/solaris-auto-install. If the -s option is not specified, that package is installed from the first publisher in the system's publisher preference list that provides an instance of that package. The -s option accepts the pkg specification as a full FMRI or location of an image ISO file. The resulting net image is eventually located in imagepath. The net image enables client installations.
Note the following specifications:
When the first install service of a given architecture is created on an install server, an alias of that service, default-i386 or default-sparc, is automatically created. This default service is used for all installations to clients of that architecture that were not added to the install server explicitly with the create-client subcommand. To change the service aliased by the default-arch service, use the set-service subcommand. To update the default-arch service, use the update-service subcommand.
If a default-arch alias is changed to a new install service and a local ISC DHCP configuration is found, this default alias boot file is set as the default DHCP server-wide boot file for that architecture.
If you want a client to use a different install service than the default for that architecture, you must use the create-client subcommand to create a client-specific configuration.
If the -i option and the -c option are used, and a DHCP server is not yet configured, an ISC DHCP server is configured.
If an ISC DHCP server is already configured, that DHCP server is updated.
Even when -i and -c arguments are provided and DHCP is configured, no binding exists between the install service being created and the IP range. When -i and -c are passed and the value of all_services/manage_dhcp is true, the IP range is set up, a new DHCP server is created if needed, and that DHCP server remains up and running for all install services and all clients to use. The network information provided to the DHCP server has no specific bearing on the service being created.
If the IP range requested is not on a subnet that the install server has direct connectivity to and the install server is multihomed, the -B option is used to provide the address of the bootfile server (usually an IP address on this system). This should only be necessary when multiple IP addresses are configured on the install server and DHCP relays are employed. In all other configurations, the software can determine this automatically.
Optional: Uses this install service name instead of a system-generated service name. The svcname can consist of alphanumeric characters, underscores (_), and hyphens (-). The first character of svcname cannot be a hyphen. The length of the svcname cannot exceed 63 characters.
If the -n option is not specified, a service name is generated automatically. The default name includes architecture and OS version information.
Optional: Specifies the data source for the net image. This can be either of:
The FMRI of an IPS AI net image package. This is the default. If the -s option is not specified, the newest available version of the install-image/solaris-auto-install package is used. The package is retrieved from the publisher specified by the -p option or from the first publisher in the install server's publisher preference list that provides an instance of the package.
The path to an AI ISO image.
Optional: Only applies when the service is being created from an IPS package. Specifies the IPS package repository from where you want to retrieve the install-image/solaris-auto-install package. An example is solaris=http://pkg.oracle.com/solaris/release/.
If the -p option is not specified, the publisher used is the first publisher in the install server's publisher preference list that provides an instance of the package.
Optional: Only applies when the service is being created from an IPS package. Specifies the architecture of the clients to be installed with this service. The value can be either i386 or sparc. The default is the architecture of the install server.
Optional: Specifies the path at which to create the net image. If not specified, the image is created in a svcname directory at the location defined by the value of the all_services/default_imagepath_basedir property. For the default value of this property, see “Install Server Configuration Properties.” A confirmation prompt is displayed unless -y is also specified.
Optional: Suppresses any confirmation prompts and proceeds with service creation using the supplied options and any default values (see -d).
Optional: This new service is an alternate name for the aliasof install service.
Optional: Specifies the starting IP address in a range to be added to the local DHCP configuration. The number of IP addresses is provided by the -c option. If a local ISC DHCP configuration does not exist, an ISC DHCP server is started if the value of all_services/manage_dhcp is true.
Optional: Sets up a total number of IP addresses in the DHCP configuration equal to the value of the count. The first IP address is the value of start that is provided by the -i option.
Optional: For x86 clients only. Sets a property value in the service-specific boot configuration file in the service image. Use this option to set boot properties that are specific to this service. This option can accept multiple comma-separated property=value pairs.
Optional: Used to provide the IP address of the boot server from which clients should request bootfiles. Only required if this IP address cannot be determined by other means.
Specifies the property and value to set.
property=value can be:
aliasof=aliasof
Makes svcname an alias of the aliasof install service.
imagepath=newpath
Relocates the imagepath of an existing service.
default-manifest=manifest
Designates a particular manifest or derived manifests script that is already registered with the specified service to be the default manifest or script for that service. Use the installadm list command to show a list of manifests and scripts registered with this service.
$ installadm list -n svcname -m
Required: Specifies the name of the install service whose property is being set.
Updates the image associated with svcname, where svcname is an alias of a service that was created using an IPS AI net image package. A new service is created with the updated image, and svcname is aliased to the new service.
The IPS package repository from which to update the svcname image. An example value is solaris=http://pkg.oracle.com/solaris/release/.
If the -p option is not specified, the publisher used is the publisher that was used to create the image of the service for which svcname is an alias. The following pkg publisher command shows how to display the svcname publisher:
$ installadm list Service Name Alias Of Status Arch Image Path ------------ -------- ------ ---- ---------- default-i386 solaris11_1-i386 on i386 /export/auto_install/solaris11_1-i386 solaris11_1-i386 - on i386 /export/auto_install/solaris11_1-i386 $ pkg -R /export/auto_install/solaris11_1-i386 publisher PUBLISHER TYPE STATUS URI solaris origin online http://pkg.oracle.com/solaris/release/
The FMRI of the net image package for the update.
If the -s option is not specified, the newest available version of the install-image/solaris-auto-install package is used from the publisher specified in the description of the -p option.
Required: Specifies the name of the install service being updated, which must be an alias of a service that was created using an IPS net image package.
Renames the install service svcname to newsvcname. The newsvcname can consist of alphanumeric characters, underscores (_), and hyphens (-). The first character of newsvcname cannot be a hyphen. The length of the newsvcname cannot exceed 63 characters.
Enables the svcname install service.
Disables the svcname install service.
Deletes an install service.
Deletes the manifests, profiles, client configuration files, and web server configuration for this install service.
Deletes the image used to instantiate the service.
If the following conditions exist, the bootfile associated with this service is removed from the ISC DHCP configuration:
The service is a default alias.
A local ISC DHCP configuration exists.
The all_services/manage_dhcp property value is true.
If specified, any clients assigned to this service, and any services aliased to this service, are also removed.
Suppresses any confirmation prompts and proceeds with service deletion.
Required: Specifies the install service name to delete.
Lists all enabled install services on a server.
Optional: Lists information about the specific install service on a local server.
If the -c option is specified, lists the client information associated with the install service.
If the -m option is specified, lists the manifests and derived manifests scripts associated with the install service.
If the -p option is specified, lists the profiles associated with the install service.
Optional: Lists the clients of the install services on a local server.
Optional: Lists the manifests and derived manifests scripts associated with the install services on a local server, including criteria for each manifest. Criteria associated with the default manifest for the service are labeled as ignored. Inactive manifests are labeled. Inactive manifests have no associated criteria and are not the default manifest for that service.
When -n is not specified, displays all manifests and scripts for all services.
When -n is specified, displays all manifests and scripts for the given service.
Optional: Lists the profiles associated with the install services on a local server, including criteria for each profile.
When -n is not specified, displays all profiles for all services.
When -n is specified, displays the profiles for the given service.
Creates a manifest or derived manifests script for a specific install service, thus making the manifest or script available on the network, independently from creating a service. A non-default manifest or script can be used (can be active) only when criteria are associated with it. Criteria can be entered on the command line (-c) or in a criteria XML file (-C). Any criteria specified along with the -d option are temporarily ignored until the manifest or script is no longer designated as the default.
The name of the manifest is determined in the following order:
The manifest name specified by the -m option, if present.
The value of the ai_instance name attribute, if present in the manifest.
The base name of the filename.
Required: Specifies the name of the install service this manifest or script is to be associated with.
Required: Specifies the path name of the manifest or derived manifests script to add.
Optional: Specifies the AI instance name of the manifest or derived manifests script. Sets the name attribute of the ai_instance element of the manifest to manifest. The manifest or script is referred to as manifest in subsequent installadm commands and installadm list output.
Optional: Specifies criteria to be associated with the added manifest or script. See the “Criteria” section below. When publishing a default manifest, criteria are registered but kept inactive until the manifest or script is no longer designated the default. The -c option can be specified multiple times.
Optional: Specifies the path name of a criteria XML file containing criteria to be associated with the added manifest or script. When publishing a default manifest or script, criteria are registered but kept inactive until the manifest or script is no longer designated the default.
Optional: Specifies that this manifest or script is the new default manifest or script for the service. Any criteria specified are stored, but these criteria are ignored until a different manifest or script is made the default.
Updates the specific manifest or derived manifests script from the svcname install service. Replaces the specified manifest or script with the contents of filename. Any criteria or default status remain with the manifest or script following the update.
The name of the manifest is determined in the following order:
The manifest specified by the -m option, if present.
The value of the ai_instance name attribute, if present in the changed manifest and if it matches the ai_instance name value of an existing manifest.
The base name of the filename, if it matches the ai_instance name attribute value in an existing manifest, or the name given by installadm list if it matches the name of an existing script.
Required: Specifies the name of the install service of the manifest or script being updated.
Required: Specifies the path name of the replacement manifest or derived manifests script.
Optional: Specifies the AI instance name of the replacement manifest or script.
Deletes a manifest or derived manifests script that was published with a specific install service. A default manifest or script cannot be deleted.
Required: Specifies the name of the install service of the manifest or script being deleted.
Required: Specifies the AI instance name of a manifest or derived manifests script as output by installadm list with the -n option.
Creates profiles for a specific install service. Criteria can optionally be associated with a profile by either entering them on the command line (-c) or in a criteria XML file (-C). Profiles created without criteria are associated with all clients of the service.
The name of the profile is determined in the following order:
The profile specified by the -p option, if present.
The base name of the filename.
Profile names must be unique for an AI service. If multiple -f options are used to create more than one profile with the same criteria, then the -p option is invalid and the names of the profiles are derived from their file names.
Required: Specifies the name of the install service of the profile being created.
Required: Specifies the path name of the file with which to add the profile. Multiple profiles can be specified.
Optional: Specifies the name of the profile being created. Valid only for single profile creation.
Optional: Specifies criteria to be associated with the profiles. See the “Criteria” section below. Multiple -c options can be specified.
Optional: Specifies the path name of a criteria XML file containing criteria to be associated with the specified profiles.
Updates the specified profile from the svcname install service. Replaces the specified profile with the contents of filename. Any criteria remain with the profile following the update.
The profile to be updated is determined in the following order:
The profile specified by the -p option, if present.
The base name of the filename.
Required: Specifies the name of the install service of the profile being updated.
Required: Specifies the path name of the file to use to update the profile.
Optional: Specifies the name of the profile being updated. Use this option if the name of the profile to update is different from the base name of the filename.
Deletes the profile profile from the svcname install service.
Required: Specifies the name of the install service of the profile being deleted.
Required: Specifies the name of the profile to delete. Multiple -p options can be specified.
Displays (exports) the specified manifests, derived manifests scripts, and profiles belonging to a specified service. At least one manifest, script, or profile must be specified. Display goes to stdout unless the -o option redirects to a file or directory.
Required: Specifies the install service associated with the manifest, script, or profile to export.
Specifies the AI instance name of a manifest or derived manifests script to export. Multiple -m options can be specified.
Specifies the name of a profile to export. Multiple -p options can be specified.
Optional: Redirect output. The pathname must be a directory if multiple manifests, scripts, or profiles are requested. The pathname can be a file if only one manifest, script, or profile is requested.
Validates specified profiles. The validate subcommand can be used to either validate profiles in the database (-p) or to validate profiles while they are being developed before their entry into the database (-P).
Required: Specifies the service with which the profiles are associated.
Specifies an external profile file to validate.
Specifies the name of the profile to validate.
Updates criteria of an already published manifest or derived manifests script, profile, or both. Criteria can be specified on the command line or in a criteria XML file. Criteria must be specified with one of the mutually exclusive options, -a, -c, or -C.
Valid criteria are described under the create-manifest subcommand.
Required: Specifies the name of the install service associated with this manifest, script, or profile.
Specifies the AI instance name of a manifest or derived manifests script.
Specifies the name of a profile. Any number of profiles can be specified.
Specifies criteria to replace all existing criteria for the manifest, script, or profile. See the “Criteria” section below.
Specifies the path name of a criteria XML file containing criteria to replace all existing criteria for the manifest, script, or profile.
Specifies criteria to be appended to the existing criteria for the manifest, script, or profile. See the “Criteria” section below. If the criteria specified already exists, the value|list|range of that criteria is replaced by the specified value|list|range.
Accomplishes optional setup tasks for a specified client, in order to provide custom client settings that vary from the default settings used by the create-service subcommand. Enables the user to specify a non-default service name and boot arguments for a client. Can also be used to modify an existing client.
If the following conditions exist, the client is configured in the ISC DHCP configuration:
The client is an x86 system.
A local ISC DHCP configuration exists.
The all_services/manage_dhcp property value is true.
Required: Specifies the install service for client installation.
Optional: For x86 clients only. Sets a property value in the client-specific boot configuration file in /etc/netboot. Use this option to set boot properties that are specific to this client. This option can accept multiple property=value pairs.
Required: Specifies a MAC address for the client.
Deletes an existing client's specific service information that was previously set up using the create-client subcommand.
If the following conditions exist, the client is unconfigured in the ISC DHCP configuration:
The client is an x86 system.
A local ISC DHCP configuration exists.
The all_services/manage_dhcp property value is true.
Required: Specifies the MAC address of the client to delete.
Manifests, derived manifests scripts, and profiles can be used to configure AI clients differently according to certain characteristics, or criteria. Only one manifest or script can be associated with a particular client. Any number of profiles can be associated with a particular client.
The criteria values are determined by the AI client during startup.
See the “Examples” section to see how to specify criteria on the command line. For information about creating a criteria file, see Installing Oracle Solaris 11.1 Systems.
|
The ipv4, mac, mem, and network specifications can be expressed as ranged values separated by a hyphen (-). To specify no limit to one end of a range, use unbounded.
The arch, cpu, hostname, platform, and zonename specifications can be expressed as a quoted list of values separated by white space.
Example 1 Set Up a New x86 Install Service From an ISO File
Set up an install server and an x86 install service for the first time. The command includes a starting IP address and total count of IP addresses, in order to configure the DHCP server.
$ pfexec installadm create-service -n sol-11_1-i386 \ -s /export/isos/sol-11_1-ai-x86.iso \ -i 172.0.0.10 -c 10 -d /export/images/sol-11_1-i386
The AI ISO image is at /export/isos/sol-11_1-ai-x86.iso. The command sets up a net image and an install service at /export/images/sol-11_1-i386 that is based on the AI ISO image. This net image enables client installations.
The starting IP address of 172.0.0.10 and ten IP addresses are added to the local ISC DHCP configuration. If a local ISC DHCP configuration does not exist, an ISC DHCP server is started.
Because this is the first x86 service created, the default-i386 service is automatically created and aliased to this service. The default-i386 alias is operational, and a client booted via PXE will boot and install from the default-i386 service.
Example 2 Set Up a New SPARC Install Service From an ISO File
Set up a SPARC install service for the first time.
$ pfexec installadm create-service -n sol-11_1-sparc \ -s /export/isos/sol-11_1-ai-sparc.iso \ -d /export/images/sol-11_1-sparc
The AI ISO image is at /export/isos/sol-11_1-ai-sparc.iso. The command sets up a net image and an install service at /export/images/sol-11_1-sparc that is based on the AI ISO image. This net image enables client installations.
Because this is the first SPARC service created, the default-sparc service is automatically created and aliased to this service. The default-sparc alias is operational, and a SPARC client will boot and install from the default-sparc service.
Example 3 Set Up an x86 Install Service From a Package Repository
If you do not specify a source for the net image, an IPS package is used.
$ pfexec installadm create-service -y
On an x86 install server, this command sets up an x86 net image and install service with a default name in a directory at the image location specified by the value of the all_services/default_imagepath_basedir property. For the default value of this property, see “Install Server Configuration Properties.” The -y option confirms that the default location is acceptable. Since the architecture is not specified, the service created is of the same architecture as the install server. This command assumes that a package repository on the pkg publisher list for the install server contains the install-image/solaris-auto-install package.
To specify the creation of a SPARC service on this server, use the -a option.
To specify the publisher of the solaris-auto-install package, use the -p option. For example, use the following command to specify the ai-image publisher located at http://example.company.com:4281 as the publisher of the solaris-auto-install package:
$ pfexec installadm create-service -y \ -p ai-image=http://example.company.com:4281
Example 4 Associate a Client With an Install Service
Use the following sample command to associate a client with a specific install service. The install service must already exist.
$ pfexec installadm create-client -b "console=ttya" \ -e 0:e0:81:5d:bf:e0 -n sol-11_1-i386
In this example, the command creates a client-specific setup for the system with MAC address 0:e0:81:5d:bf:e0. This client will use the install service previously set up, named sol-11_1-i386, and that service's associated net image. The command sets the boot property console=ttya in the client-specific boot configuration file in /etc/netboot.
Example 5 Add a New Install Service Without Modifying the Default Service
Use the following sample command to add a new service named sol-11-sparc, retaining existing services, and leaving the existing default unchanged.
$ pfexec installadm create-service -n sol-11-sparc \ -s /export/isos/sol-11-1111-ai-sparc.iso \ -d /export/ai/sol-11-sparc
Example 6 Update the default-i386 Service
Use the following sample command to update the default-i386 alias service to be associated with the latest available image. The installadm list command shows the service before and after the command. The example assumes that an updated net image package is available from the publisher that was originally used to create the default-i386 service alias.
$ installadm list Service Name Alias Of Status Arch Image Path ------------ -------- ------ ---- ---------- default-i386 solaris11-i386 on i386 /export/images/solaris11-i386 solaris11-i386 - on i386 /export/images/solaris11-i386 $ pfexec installadm update-service default-i386 ... Creating new i386 service: solaris11_1-i386 Aliasing default-i386 to solaris11_1-i386 ... ... $ installadm list Service Name Alias Of Status Arch Image Path ------------ -------- ------ ---- ---------- default-i386 solaris11_1-i386 on i386 /export/images/solaris11_1-i386 solaris11-i386 - on i386 /export/images/solaris11-i386 solaris11_1-i386 - on i386 /export/images/solaris11_1-i386
Example 7 Add a New Install Service and Update the default-sparc Service
Use the following two sample commands to add a new service named my-sparc-service, retaining existing services, and making the new service the default for SPARC clients.
$ pfexec installadm create-service -n solaris11_1-sparc \ -s /export/isos/sol-11_1-ai-sparc.iso \ -d /export/ai/solaris11_1-sparc $ pfexec installadm set-service \ -o aliasof=solaris11_1-sparc default-sparc
Example 8 Add a Custom Default AI Manifest to an Install Service
Use the following sample command to add a new manifest to the sol-11_1-i386 install service, and make it the service's default manifest. The manifest data is in my_default.xml. Future installadm commands will refer to this manifest as my_default.
$ pfexec installadm create-manifest -d -f my_default.xml \ -m my_default -n sol-11_1-i386
Example 9 Add a Derived Manifests Script to an Install Service
Use the following sample command to add a derived manifests script named my_script to an existing install service named solaris11_1-i386. Scripts are added in the same way that manifests are added.
$ pfexec installadm create-manifest -f my_script.py \ -m my_script -n solaris11_1-i386
See Installing Oracle Solaris 11.1 Systems for information about how to create derived manifests scripts.
Example 10 Replace the Default AI Manifest for an Install Service
Use the following sample command to replace the default manifest for an existing install service, sol-11_1-sparc, with a custom manifest that has already been added to the service as custom_manifest. The manifest was added to the service by specifying -m custom_manifest to the create-manifest subcommand.
$ pfexec installadm set-service \ -o default-manifest=custom_manifest sol-11_1-sparc
Example 11 List Install Services
Use the following sample command to list the install services on a local server.
$ installadm list Service Name Alias Of Status Arch Image Path ------------ -------- ------ ---- ---------- default-i386 sol-11_1-i386 on i386 /export/images/sol-11_1-i386 default-sparc sol-11_1-sparc on sparc /export/images/sol-11_1-sparc sol-11_1-i386 - on i386 /export/images/sol-11_1-i386 sol-11_1-sparc - on sparc /export/images/sol-11_1-sparc
Example 12 List Clients Associated With an Install Service
Use the following sample command to list the clients of a specific install service on a local server.
$ installadm list -c -n sol-11_1-i386 Service Name Client Address Arch Image Path ------------ -------------- ---- ---------- sol-11_1-i386 01:C2:52:E6:4B:E1 i386 /export/images/sol-11_1-i386
Example 13 List Manifests Associated With an Install Service
Use the following sample command to list the manifests and derived manifests scripts associated with a specific install service on a local server.
$ installadm list -m -n sol-11_1-sparc Service/Manifest Name Status Criteria --------------------- ------ -------- sol-11_1-sparc mem mem = 4096 MB - unbounded custom_manifest Default (Ignored: mem = 2048 MB - 4095 MB) orig_default Inactive None
This example shows the following output:
A non-default manifest with criteria (mem)
A default manifest with criteria that are ignored (custom_manifest)
A non-default manifest (orig_default) that is marked inactive because it has no criteria
Example 14 List Profiles
Use the following sample command to list the system configuration profiles for all install services on a local server.
$ installadm list -p Service/Profile Name Criteria -------------------- -------- sol-11_1-i386 sc_all-x86.xml None sol-11_1-sparc sc_all-sparc.xml None sc_network.xml network = 10.0.0.0 ipv4 = 10.0.2.100 - 10.0.2.199
Example 15 Add a Custom AI Manifest With No Name to an Install Service
Use the following sample command to add the manifest in /export/my_manifest.xml to sol-11_1-i386 with a criterion of MAC address equaling aa:bb:cc:dd:ee:ff.
$ pfexec installadm create-manifest \ -f /export/my_manifest.xml -n sol-11_1-i386 \ -c mac="aa:bb:cc:dd:ee:ff"
In this example, the manifest does not contain a name attribute, so the manifest name is taken from the file name.
$ installadm list -m -n sol-11_1-i386 Service/Manifest Name Status Criteria --------------------- ------ -------- sol-11_1-i386 my_manifest.xml mac = AA:BB:CC:DD:EE:FF orig_default Default None
Example 16 Add a Custom AI Manifest With a Custom Name to an Install Service
Use the following sample command to add the manifest in /export/my_manifest.xml to sol-11_1-i386 with the criterion of IPv4 range from 10.0.2.100 and 10.0.2.199.
$ pfexec installadm create-manifest \ -f /export/my_manifest.xml \ -n sol-11_1-i386 -m custom_name \ -c ipv4="10.0.2.100-10.0.2.199"
In this example, the manifest name is taken from the -m option.
$ installadm list -m -n sol-11_1-i386 Service/Manifest Name Status Criteria --------------------- ------ -------- sol-11_1-i386 custom_name ipv4 = 10.0.2.100 - 10.0.2.199 orig_default Default None
Example 17 Add a Custom AI Manifest With Name Specified In the Manifest
Use the following sample command to add the manifest in /export/manifest3.xml to sol-11_1-i386 with criteria of 2048 MB memory or greater and an architecture of i86pc.
$ pfexec installadm create-manifest \ -f /export/manifest3.xml -n sol-11_1-i386 \ -c mem="2048-unbounded" -c arch=i86pc
In this example, the manifest name is taken from the name attribute of the ai_instance element in the manifest, as shown in the following partial manifest:
<auto_install> <ai_instance name="my_name" /> </auto_install>
$ installadm list -m -n sol-11_1-i386 Service/Manifest Name Status Criteria --------------------- ------ -------- sol-11_1-i386 my_name arch = i86pc mem = 2048 MB - unbounded orig_default Default None
Example 18 Add a System Configuration Profile To an Install Service
Use the following sample command to add the profile in /export/profile4.xml to sol-11_1-i386 with criteria of any of the host names myhost1, host3, or host6.
$ pfexec installadm create-profile \ -f /export/profile4.xml -n sol-11_1-i386 -p profile4 \ -c hostname="myhost1 host3 host6" $ installadm list -p -n sol-11_1-i386 Service/Profile Name Criteria -------------------- -------- sol-11_1-i386 profile4 hostname = myhost1 host3 host6
Example 19 Add a System Configuration Profile For All Clients
If you do not specify criteria, then the profile is used by all clients that use the specified install service. In the following example, the created profile is used by all clients that use the sol-11_1-i386 service.
$ pfexec installadm create-profile -f /export/locale.xml \ -n sol-11_1-i386 $ installadm list -p -n sol-11_1-i386 Service/Profile Name Criteria -------------------- -------- sol-11_1-i386 profile4.xml hostname = myhost1 host3 host6 locale.xml
Example 20 Add a System Configuration Profile With Variables
A profile can use variables that are replaced with custom client configuration information at client installation time. Using such variables, a profile file can be reused for any number of different systems.
This example uses one system configuration profile file to assign each install client a unique host name. The hostname.xml file contains the following line:
<propval name="nodename" value="{{AI_HOSTNAME}}"/>
At installation time, {{AI_HOSTNAME}} is replaced with the actual host name of that system. For example, when hostname.xml is used to configure the client with host name myhost1, the hostname.xml profile contains the following line:
<propval name="nodename" value="myhost1"/>
For more information about using replacement tags with profiles, see Using System Configuration Profile Templates in Installing Oracle Solaris 11.1 Systems.
Example 21 Add Criteria To an Existing Manifest
Use the following sample command to append the criterion of 4096 MB memory or greater to the criteria of manifest2 of sol-11_1-i386.
$ pfexec installadm set-criteria -m manifest2 \ -n sol-11_1-i386 -a mem="4096-unbounded"
Example 22 Replace the Criteria for an Existing Manifest
Use the following sample command to replace the criteria of manifest2 of sol-11_1-i386 with the criteria specified in the file /tmp/criteria.xml.
$ pfexec installadm set-criteria -m manifest2 \ -n sol-11_1-i386 -C /tmp/criteria.xml
See Installing Oracle Solaris 11.1 Systems for information about the contents of the criteria XML file.
Example 23 Validate Profile Files Under Development
Use the following sample command to validate the profiles stored in the files myprofdir/myprofile.xml and yourprofdir/yourprofile.xml during their development.
$ pfexec installadm validate -P myprofdir/myprofile.xml \ -P yourprofdir/yourprofile.xml -n sol-11_1-i386
Example 24 Export Profile Contents
Use the following sample command to export the profile myprofile.xml in the service sol-11_1-i386.
$ installadm export -p myprofile -n sol-11_1-i386
Example 25 Replace the Contents of an Existing AI Manifest
Use the following sample command to update the manifest in service sol-11_1-i386 that has the manifest name, or AI instance name, spec with the contents of the manifest in the file /home/admin/new_spec.xml.
$ pfexec installadm update-manifest -n sol-11_1-i386 \ -f /home/admin/new_spec.xml -m spec
Example 26 Export and Update an Existing AI Manifest
Use the following sample commands to export the data of an existing manifest named spec in service sol-11_1-i386, and then update the manifest with modified content.
$ pfexec installadm export -n sol-11_1-i386 -m spec \ -o /home/admin/spec.xml
Make changes to /home/admin/spec.xml.
$ pfexec installadm update-manifest -n sol-11_1-i386 \ -f /home/admin/spec.xml -m spec
Example 27 Export and Update an Existing Profile
Use the following sample commands to export the data of an existing profile named prof1 in service sol-11_1-i386, and then update the profile with modified content.
$ pfexec installadm export -n sol-11_1-i386 -p prof1 \ -o /home/admin/prof1.xml
Make changes to /home/admin/prof1.xml.
$ pfexec installadm update-profile -n sol-11_1-i386 \ -f /home/admin/prof1.xml -p prof1
The following exit values are returned:
The command was processed successfully.
An error occurred.
Invalid command line options were specified.
A service's version is not supported by installadm.
No changes were made - nothing to do.
See attributes(5) for descriptions of the following attributes:
|
aimanifest(1M), sysconfig(1M), dhcp(5), smf(5), service_bundle(4), ai_manifest(4), environ(5)
Part III, Installing Using an Install Server, in Installing Oracle Solaris 11.1 Systems
Transitioning From Oracle Solaris 10 JumpStart to Oracle Solaris 11.1 Automated Installer