Skip Navigation Links | |
Exit Print View | |
man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library |
- parse ifconfig command line
/usr/sbin/ifparse [-fs] addr_family commands
Use the ifparse command to parse the ifconfig(1M) command line options and output substrings, one per line, as appropriate. If no options are specified, ifparse returns the entire ifconfig command line as a series of substrings, one per line.
The ifparse command supports the following options:
Lists only substrings of the ifconfig command line that are relevant to IP network multipath failover
Lists only substrings of the ifconfig command line that are not relevant to IP network multipath failover
The ifparse command does not support the interface operand of the ifconfig command.
Example 1 Parsing Command Line Options Relevant to Failover
The following example shows the use of the ifparse command to parse the command line options relevant to IP network multipath failover:
example# ifparse -f inet 1.2.3.4 up group one addif 1.2.3.5 -failover up set 1.2.3.4 up
Example 2 Parsing Command Line Options That Are Not Relevant to Failover
The following example shows the use of the ifparse command to parse the command line options that are not relevant to IP network multipath failover:
example# ifparse -s inet 1.2.3.4 up group one addif 1.2.3.5 -failover up group one addif 1.2.3.5 -failover up
Example 3 Parsing the Command Line For All Options
The following example shows the use of the ifparse command to parse the command line for all ifconfig options:
example# ifparse inet 1.2.3.4 up group one addif 1.2.3.5 -failover up group one set 1.2.3.4 up addif 1.2.3.5 -failover up
See attributes(5) for descriptions of the following attributes:
|
usage: -fs <addr_family> <commands>
Description: This message indicates an invalid command line.
ifparse: Not enough space
Description: This message indicates insufficient memory.
ifparse: dhcp not supported for inet6
Description: DHCP operations are not supported for the inet6 address family.
ifparse: Operation <operation> not supported for <addr_family>
Description: Most operations cannot be used with all address families. For example, the broadcast operation is not supported on the inet6 address family.
ifparse: no argument for <operation>
Description: Some operations, for example broadcast, require an argument.
The ifparse command is classified as an obsolete interface. It will likely be removed in a future release. You should not develop applications that depend upon this interface.