Skip Navigation Links | |
Exit Print View | |
man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library |
- Link Layer Discovery Protocol administration tool
lldpadm set-agentprop -p prop[+|-]=value[,...] lldp_agent lldpadm reset-agentprop -p prop[,...] lldp_agent lldpadm show-agentprop [[-c] -o field,...] -p prop[,...] [lldp_agent]
lldpadm set-tlvprop -p prop[+|-]=value[,...] tlv_name lldpadm reset-tlvprop -p prop[,...] tlv_name lldpadm show-tlvprop [[-c] -o field,...] -p prop[,...] [tlv_name]
lldpadm set-agenttlvprop -p prop[+|-]=value[,...] -a lldp_agent tlv_name lldpadm reset-agenttlvprop -p prop[,...] -a lldp_agent tlv_name lldpadm show-agenttlvprop [[-c] -o field,...] -p prop[,...] [-a lldp_agent] [tlv_name]
lldpadm show-agent [-c] [-s] [-v] -o field,...] [-l|-r] [lldp_agent]
The lldpadm command is used to enable or disable a Link Layer Discovery Protocol (LLDP) agent on a physical datalink. lldpadm is also used to configure the behavior of an LLDP agent. The LLDP agent implements the LLDP protocol for a given physical datalink. LLDP is a one-way link layer protocol that allows an IEEE 802 LAN station to advertise the capabilities and current status of the system to other stations attached to the same LAN. The LLDP agent can also receive information about the capabilities and current status of the system associated with a remote station. LLDP agent can either be enabled for transmission only, for reception only, or for both.
Information to be exchanged is packed as a sequence of type, length, and value (TLVs), wherein the type field identifies the type of information, the length field indicates the length of the information field in octets, and the value field contains the information itself.
Each lldpadm subcommand operates on one of the following objects:
An LLDP agent implements the LLDP protocol for a given physical datalink that is connected to IEEE 802 LAN. The only supported physical links are the ones of media type Ethernet. Thus, LLDP can be enabled on all the links displayed in dladm show-phys output that are of media type Ethernet. The name of the lldp_agent is the name of the datalink itself.
Name of the TLV whose value can be modified. The supported modifiable TLVs are:
syscapab and mgmtaddr. These form Global TLVs that are common to all the LLDP agents on the system.
pfc, ets, and appln. Per-LLDP agent TLVs.
lldpadm supports the following subcommands.
Sets the value of one or more LLDP agent properties to the value specified. If the property takes multiple values then the value should be specified with a comma as the delimiter. The value is always made persistent and thus will be reapplied on system reboot or lldpd(1M) daemon restart. The list of properties supported and each property's possible values can be retrieved using show-agentprop subcommand.
A comma-separated list of properties to be set to the specified values. It also provides the following qualifiers to perform add and delete operations in addition to assignment.
Adds the given value to the current list of value(s).
Removes the given value from the current list of value(s).
Makes a new assignment and removes all the current value(s).
See EXAMPLES for more information on how to use the qualifiers.
Resets one or more properties to their default values. The default values for properties can be retrieved using show-agentprop subcommand.
A comma-separated list of properties to reset.
Show the current value of one or more properties, either for all of the LLDP agents or for the specified LLDP agent. Several properties of interest can be retrieved at a time by providing comma-separated property names to -p option. If the -p option is not specified, all available properties are displayed.
A case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed below, or the special value all to display all fields. For each LLDP agent, the following fields can be displayed:
The name of the LLDP agent.
The name of the property.
The read/write permissions of the property. The value shown will be r (read only), w (write only) or rw (read/write).
The current value of the property. If the value is not set, it is shown as --. If it is unknown, the value is shown as ?.
The default value of the property. If the property has no default value, -- is shown.
A comma-separated list of the values the property can have. If the values span a numeric range, min - max might be shown as shorthand. If the possible values are unknown or unbounded, -- is shown.
Display using a stable machine-parsable format. The -o option is required with this option. See “Parsable Output Format”, below.
A comma-separated list of properties to display.
For the supported list of agent properties, see “Agent Properties” section below.
Sets the value of one or more TLV properties to the value specified. If the property takes multiple values, the value should be specified with a comma as the delimiter. The value is always persisted and will be reapplied on system reboot or lldpd(1M) daemon restart. The list of properties supported and each property's possible values can be retrieved using show-tlvprop subcommand.
Note - The TLVs modified using this subcommand apply to all the LLDP agents running on the system.
See the description of this option under the set-agentprop subcommand, above.
Resets one or more properties to their default values. The default values for properties can be retrieved using show-tlvprop subcommand.
A comma-separated list of properties to reset.
Show the current value of one or more properties, either for all the TLVs or for a specified TLV. Several properties of interest can be retrieved at a time by providing comma-separated property names to -p option. If the -p option is not specified, all available properties are displayed.
A case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed below, or the special value all to display all fields. For each TLV, the following fields can be displayed:
The name of the TLV.
The name of the property.
The read/write permissions of the property. The value shown will be r (read only), w (write only) or rw (read/write).
The current value of the property. If the value is not set, it is shown as --. If it is unknown, the value is shown as ?.
The default value of the property. If the property has no default value, -- is shown.
A comma-separated list of the values the property can have. If the values span a numeric range, min - max might be shown as shorthand. If the possible values are unknown or unbounded, -- is shown.
Display using a stable machine-parsable format. The -o option is required with this option. See “Parsable Output Format”, below.
A comma-separated list of properties to display.
Sets the value of one or more TLV properties to the value specified. The -a option is mandatory and identifies the name of the agent for which the TLV property needs to be set. In this way, the TLV property modification is reflected only on the specified agent. If the property takes multiple values then the value should be specified with a comma as the delimiter. The value is always made persistent and will be reapplied on system reboot or lldpd(1M) daemon restart. The list of properties supported and each property's possible values can be retrieved using show-agenttlvprop subcommand.
See the description of this option under the set-agentprop subcommand, above.
The name of the LLDP agent for which TLV properties need to be displayed.
Resets one or more properties to their default values. The -a option is mandatory and identifies the name of the agent for which the TLV property needs to be reset. The default values for properties can be retrieved using show-agenttlvprop subcommand.
A comma-separated list of properties to display.
The name of the LLDP agent for which TLV properties need to be displayed.
Show the current value of one or more properties, either for all of the TLVs or for a specified TLV. If a single LLDP agent is not specified (using -a), TLV properties for all LLDP agents are displayed. Several properties of interest can be retrieved at a time by providing comma-separated property names to the -p option. If the -p option is not specified, all available properties are displayed.
A case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed below, or the special value all to display all fields. For each LLDP agent, the following fields can be displayed:
The name of the LLDP agent.
The name of the TLV.
The name of the property.
The read/write permissions of the property. The value shown will be r (read only), w (write only) or rw (read/write).
The current value of the property. If the value is not set, it is shown as --. If it is unknown, the value is shown as ?.
The default value of the property. If the property has no default value, -- is shown.
A comma-separated list of the values the property can have. If the values span a numeric range, min - max might be shown as shorthand. If the possible values are unknown or unbounded, -- is shown.
Display using a stable machine-parsable format. The -o option is required with this option. See “Parsable Output Format”, below.
A comma-separated list of properties to display.
The name of the LLDP agent for which TLV properties need to be displayed.
For the supported list of TLV properties that apply on a per-LLDP agent basis, see the “Per-LLDP agent TLV properties” section, below.
Show the information advertised by the specified LLDP agent or information advertised by the adjacent neighbors to the specified LLDP agent. If no LLDP agent is specified, then the local or remote information will be displayed for all the LLDP agents. The information is displayed as a multi-line output, with each line containing information about a single TLV in the following format:
<Name of the TLV> : <TLV Information expressed as a string>
The following lines can be displayed:
Agent: Chassis ID Subtype: Chassis ID: Port ID Subtype: Port ID: Port Description: Time to Live: System Name: System Description: Supported Capabilities: Enabled Capabilities: Management Address: Maximum Frame Size: Port VLAN ID: VLAN Name/ID: VNIC PortID/VLAN ID: Aggregation Information: PFC Willing: PFC Cap: PFC MBC: PFC Enable: PFC Pending: [displayed only when -l is used] ETS Willing: ETS Configured CBS: ETS Configured TCS: ETS Configured PAT: ETS Configured BAT: ETS Configured TSA: ETS Recommended PAT: ETS Recommended BAT: ETS Recommended TSA: Application(s)(ID/Sel/Pri): EVB Mode: EVB GID (Station): EVB RRREQ: EVB RRSTAT: EVB GID (Bridge): EVB RRCAP: EVB RRCTR: EVB R: EVB RTE: EVB ROL RWD: EVB RWD: EVB ROL RKA: EVB RKA: Next Packet Transmission: [displayed only when -l is used] Information Valid Until: [displayed only when -r is used]
In preceding output, the ETS parameters are described as follows:
Indicates whether Credit-Based Shaper is supported.
Number of Traffic Classes supported.
Priority Assignment Table.
Bandwidth Assignment Table.
Transmission Selection Algorithm supported.
Values that will be recommended to the peer.
Display using a stable machine-parsable format. The -o option is required with this option. See “Parsable Output Format”, below.
Displays information advertised by the local LLDP agent. This option is mutually exclusive of the -r option.
Displays information advertised by the adjacent neighbors. This option is mutually exclusive of the -l option.
Show the statistics for the specified LLDP agents or for all the LLDP agents on the system. Every LLDP agent maintains statistical counters that are used to count significant events in the transmit and receive state machines. These counters are defined to be 32-bit unsigned integers.
A case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed below, or the special value all to display all fields. For each TLV, the following fields can be displayed:
The name of the LLDP agent.
Count of all LLDP frames received by AGENT.
Count of all LLDPDUs received with one or more detectable errors.
Count of all LLDPDUs received and then discarded for any of the following reasons:
incorrectly formed LLDPDUs with respect to the first three mandatory TLVs
insufficient space to store the incoming LLDPDU
Count of all LLDP frames transmitted by AGENT.
Count of times the outgoing LLDPDU exceeded the length restrictions of 1500 bytes.
Count of all TLVs received and then discarded because the TLVs did not adhere to the TLV usage rules as specified by the standard.
Count of all TLVs received that are not recognized by the LLDP agent.
Count of the times that a neighbor's information has been deleted because of aging.
Displays detailed information.
The lldpadm show subcommands have a -c option that displays output in a machine-parsable format. The output format is one or more lines of colon (:)-delimited fields. The fields displayed are specific to the subcommand used and are listed under the entry for the -o option for a given subcommand. Output includes only those fields requested by means of the --o option, in the order requested. Note that the -o all option, which displays all the fields for a given subcommand, cannot be used with the parsable output option.
When you request multiple fields, any literal colon characters are escaped by a backslash (\) before being output. Similarly, literal backslash characters are also escaped with a backslash. This escape format is parsable by using shell read(1) functions with the environment variable set as IFS=: Note that escaping is not done when you request only a single field.
The following LLDP agent properties are supported:
Configures the operation mode of the LLDP agent. Possible values are:
Enables LLDP for transmission only.
Enables LLDP for receiving only.
Enables LLDP for both transmission and receiving.
Disables LLDP on the LLDP agent.
Every LLDP packet (LLDPDU) transmitted by an LLDP agent contains multiple TLVs. The following four TLVs are mandatory and therefore included in all the LLDPDUs transmitted by an agent configured in the txonly or both mode:
The value transmitted in the Chassis ID TLV is:
subtype = 7 (locally assigned)
Chassis ID = hostid(1)
The value transmitted in the Port ID TLV is:
subtype = 3 (MAC address)
Port ID = primary MAC address of the agent
The duration for which this packet is valid. The default value is 30 seconds.
End of PDU indicator.
Optional TLVs that can be advertised are configured using the following properties:
Configures the Basic Management TLVs that should be advertised by the LLDP agent. The possible values are:
Alphanumeric string that identifies the datalink. Value set to the linkname.
Alphanumeric string that identifies the system. Value set to the output of 'uname -n'.
Alphanumeric string that describes the system. Value set to the output of 'uname -a'.
Indicates the systems supported and enabled capabilities.
Indicates the IP address of the system that can be used by network management.
Configures the IEEE 802.1 Organizationally Specific TLVs that should be advertised by the LLDP agent. The possible values are:
Indicates the names and IDs of all the VLANS configured on the datalink.
Indicates the default VLAN ID associated with the given datalink. It corresponds to the default_tag datalink property that is managed by means of the dladm(1M) utility.
Indicates whether underlying datalink is in an aggregation or is capable of being part of an aggregation.
Indicates whether underlying datalink supports PFC (Priority Flow Control) and the priorities for which the PFC pause frame is enabled. Also indicates whether the local endpoint is willing to negotiate the PFC configuration.
Indicates the ETS (Enhanced Transmission Selection) configuration on the host when the underlying physical link supports ETS feature. Also indicates whether the local endpoint is willing to negotiate the ETS configuration.
Indicates the priority that will be used by an application.
Configures the IEEE 802.3 Organizationally Specific TLVs that should be advertised by the LLDP agent. The possible values are:
Indicates the maximum supported frame size for the underlying datalink.
Configures the Solaris's Virtualization Specific TLVs that should be advertised by the LLDP agent. The possible values are:
Indicates the MAC address of the Virtual NIC created on top of the underlying physical link. Also indicates any VLAN id associated with the VNIC. See dladm(1M) for more information on VNIC.
The following Global TLV properties are supported:
This property can one of the following values:
Indicates the supported capabilities on the system. The default supported capabilities are: bridge, router, and station.
Indicates the enabled capabilities on the system. The enabled capabilities must be a subset of the supported capabilities.
This property can have the following value:
The IP address(es), either IPv4 or IPv6, associated with the local LLDP agent that will be used to reach higher layer entities to assist discovery by network management.
The following Agent TLV properties are supported:
This property can have the following value:
Configures the Application Priority Table for an Application TLV. One can add or remove entries from this table using the + and - qualifiers. Each entry in the table indicates the application and the priority that will be used for that application. Its value is of the form:
id/selector/priority
The meaning of the id is determined by the selector field. The selector field can be any one of the following:
1 — id indicates an Ethertype (an L2 protocol), therefore id's value should be greater than 1536
2 — id indicates a port number over TCP or SCTP
3 — id indicates a port number over UDP or DCCP
4 — id indicates a port number over TCP, SCTP, UDP, or DCCP
The priority indicates the priority value (0-7) that will be used for given application.
This property can have the following value:
Indicates whether the host is willing to accept the peer's ETS recommendation. This property is likely to change in the future.
This property can have the following value:
Configures the willingness to accept the configuration from the remote peer and change the operational configuration on the host locally for a Priority-based Flow Control TLV. Its value can be on (default) or off. This property is subject to change in future releases.
The following subcommands require solaris.network.lldp authorization:
set-agentprop
reset-agentprop
set-tlvprop
reset-tlvprop
set-agenttlvprop
reset-agenttlvprop
The various show-* subcommands do not need any authorization.
Example 1 Enabling LLDP Protocol on an LLDP Agent
The following command enables the LLDP protocol on an LLDP agent for both transmission and reception of LLDPDUs.
# lldpadm set-agentprop -p mode=both net0
Example 2 Disabling LLDP Protocol on an LLDP Agent
The following command disables the LLDP protocol on an LLDP agent.
# lldpadm set-agentprop -p mode=disable net0
Example 3 Configuring TLVs
The following command configures transmission of the Port Description and System Name TLV.
# lldpadm set-agentprop -p basic-tlv=portdesc,sysname net0
The following command configures transmission of a VLAN Name TLV and a Link Aggregation TLV.
# lldpadm set-agentprop -p dot1-tlv=vlanname net0 # lldpadm set-agentprop -p dot1-tlv+=linkaggr net0
The following command configures transmission of all dot3-tlvs.
# lldpadm set-agentprop -p dot3-tlv=all net0
All the above lldpadm invocations can be combined into the following, single invocation.
# lldpadm set-agentprop -p basic-tlv=portdesc,sysname,\ dot1-tlv=vlanname,linkaggr,dot3-tlv=all net0
Example 4 Disabling Transmission
The following command disables the transmission of all dot1-tlvs out of an LLDP agent.
# lldpadm set-agentprop -p dot1-tlv=none net0
The following command is equivalent to the preceding.
# lldpadm reset-agentprop -p dot1-tlv net0
Example 5 Configuring Enabled Capabilities
The following command configures the enabled capabilities on a system.
# lldpadm set-tlvprop -p enabled=router syscapab
With this configuration, when an LLDP agent is enabled for advertising a System Capabilities TLV, the adjacent neighbors would learn of the local system's capabilities.
Example 6 Configuring a Management Address for Subsequent Advertising
The following command configures the management address that will be advertised by means of the Management Address TLV.
# lldpadm set-tlvprop -p ipaddr=192.168.1.2 mgmtaddr
Note that this address would be identified as an address associated with the local LLDP agent that will be used to reach higher layer entities to assist discovery by network management.
Example 7 Configuring an Application TLV
The following sequence of commands configures the application TLV to advertise the priority that will be used by FCoE.
# lldpadm set-agenttlvprop -p apt=8906/1/4 -a net0 appln # lldpadm show-agenttlvprop -a net0 appln AGENT TLVNAME PROPERTY PERM VALUE DEFAULT POSSIBLE net0 appln apt rw 8906/1/4 -- --
Example 8 Show Local Information Advertised by LLDP Agent
The following commands show, respectively, brief and detailed local information advertised by an LLDP agent.
Brief information:
# lldpadm show-agent -l net0 AGENT CHASSISID PORTID net0 004bb87f 00:14:4f:01:77:5d
Detailed information:
# lldpadm show-agent -lv net0 Agent: net0 Chassis ID Subtype: Local(7) Chassis ID: 004bb87f Port ID Subtype: MacAddress(3) Port ID: 00:14:4f:01:77:5d Port Description: net0 Time to Live: 81 (seconds) System Name: hosta.example.com System Description: SunOS 5.11 dcb-clone-x-01-19-11 i86pc Supported Capabilities: bridge, router, station Enabled Capabilities: router Management Address: 192.168.1.2 Maximum Frame Size: 3000 Port VLAN ID: -- VLAN Name/ID: vlan25/25 VNIC PortID/VLAN ID : -- Aggregation Information: Capable, Not Aggregated PFC Willing: -- PFC Cap: -- PFC MBC: -- PFC Enable: -- PFC Pending: -- ETS Configured CBS: 0 ETS Configured TCS: 8 ETS Configured PAT: 0,1,2,3,4,5,6,7 ETS Configured BAT: 70,30,0,0,0,0,0,0 ETS Configured TSA: 2,2,2,2,2,2,2,2 ETS Recommended PAT: -- ETS Recommended BAT: -- ETS Recommended TSA: -- Application(s)(ID/Sel/Pri): -- EVB Mode: Station EVB GID (Station): Not Supported EVB RRREQ: Not Requested EVB RRSTAT: RR Unknown EVB GID (Bridge): Not Supported EVB RRCAP: Not Supported EVB RRCTR: Not Enabled EVB R: 3 EVB RTE: 20 EVB ROL RWD: Local EVB RWD: 20 EVB ROL RKA: Local EVB RKA: 20 Next Packet Transmission: 18 (seconds)
The above ETS-related information indicates that CBS is not supported, 8 Traffic Classes are supported, there is a 1-to-1 mapping between the priority and the Traffic Class, the bandwidth allocation among the Traffic Classes are 70,30, 000000, and the transmission algorithm used for all the Traffic Classes is ETS.
Example 9 Show Remote Information about Adjacent Devices for an LLDP Agent
The following commands show, respectively, brief and detailed remote information about adjacent devices for a given LLDP agent.
Brief information:
# lldpadm show-agent -r net0 AGENT SYSNAME CHASSISID PORTID net0 hostb 0083b390 00:14:4f:01:59:ab
Detailed information:
# lldpadm show-agent -rv net0 Agent: net0 Chassis ID Subtype: Local(7) Chassis ID: 0083b390 Port ID Subtype: MacAddress(3) Port ID: 00:14:4f:01:59:ab Port Description: net0 Time to Live: 121 (seconds) System Name: hostb.example.com System Description: SunOS 5.11 dcb-clone-x-01-19-11 i86pc Supported Capabilities: bridge, router, station Enabled Capabilities: router Management Address: 192.168.1.3 Maximum Frame Size: 3000 Port VLAN ID: -- VLAN Name/ID: vlan25/25 VNIC PortID/VLAN ID : 02:08:20:72:71:31 Aggregation Information: Capable, Not Aggregated PFC Willing: -- PFC Cap: -- PFC MBC: -- PFC Enable: -- PFC Pending: -- ETS Configured CBS: 0 ETS Configured TCS: 8 ETS Configured PAT: 0,1,2,3,4,5,6,7 ETS Configured BAT: 100,0,0,0,0,0,0,0 ETS Configured TSA: 2,2,2,2,2,2,2,2 ETS Recommended PAT: -- ETS Recommended BAT: -- ETS Recommended TSA: -- Application(s)(ID/Sel/Pri): -- EVB Mode: Bridge EVB GID (Station): Not Supported EVB RRREQ: Not Requested EVB RRSTAT: RR Unknown EVB GID (Bridge): Not Supported EVB RRCAP: Not Supported EVB RRCTR: Not Enabled EVB R: 3 EVB RTE: 20 EVB ROL RWD: Local EVB RWD: 20 EVB ROL RKA: Local EVB RKA: 20 Information Valid Until: 117 (seconds)
Example 10 Show LLDP Agent Statistics
The following command displays LLDP agent statistics.
# lldpadm show-agent -s net0 AGENT IFRAMES IERR IDISCARD OFRAMES OLENERR TLVDISCARD TLVUNRECOG AGEOUT net0 44 0 0 57 0 0 0 0
See attributes(5) for descriptions of the following attributes:
/sbin
|
hostid(1), read(1), uname(1), dladm(1M), lldpd(1M), svcadm(1M), attributes(5)
IEEE Std 802.1AB-2009, IEEE Standard for Local and Metropolitan Area Networks: Station and Media Access Control Connectivity Discovery
IEEE Draft 802.1Qbb, Virtual Bridged Local Area Networks - Amendment : Priority-based Flow Control
IEEE Draft 802.1Qaz, Virtual Bridged Local Area Networks - Amendment XX: Enhanced Transmission Selection for Bandwidth Sharing between Traffic Classes
The lldpd(1M) daemon that implements the LLDP protocol must be first enabled before using the lldpadm command. The lldpd daemon is controlled through the service management facility (SMF) service instance:
svc:/network/lldp:default
Use svcadm(1M) to enable this service.