Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library |
csx_AccessConfigurationRegister(9F)
csx_Parse_CISTPL_BYTEORDER(9F)
csx_Parse_CISTPL_CFTABLE_ENTRY(9F)
csx_Parse_CISTPL_DEVICEGEO(9F)
csx_Parse_CISTPL_DEVICEGEO_A(9F)
csx_Parse_CISTPL_DEVICE_OA(9F)
csx_Parse_CISTPL_DEVICE_OC(9F)
csx_Parse_CISTPL_LINKTARGET(9F)
csx_Parse_CISTPL_LONGLINK_A(9F)
csx_Parse_CISTPL_LONGLINK_C(9F)
csx_Parse_CISTPL_LONGLINK_MFC(9F)
ddi_get_soft_iblock_cookie(9F)
ddi_intr_get_supported_types(9F)
ddi_prop_lookup_byte_array(9F)
ddi_prop_lookup_int64_array(9F)
ddi_prop_lookup_string_array(9F)
ddi_prop_update_byte_array(9F)
ddi_prop_update_int64_array(9F)
ddi_prop_update_string_array(9F)
ldi_prop_lookup_byte_array(9F)
ldi_prop_lookup_int64_array(9F)
ldi_prop_lookup_string_array(9F)
mac_prop_info_set_default_link_flowctrl(9F)
mac_prop_info_set_default_str(9F)
mac_prop_info_set_default_uint8(9F)
mac_prop_info_set_range_uint32(9F)
net_event_notify_unregister(9F)
net_instance_notify_register(9F)
net_instance_notify_unregister(9F)
net_instance_protocol_unregister(9F)
net_protocol_notify_register(9F)
nvlist_lookup_boolean_array(9F)
nvlist_lookup_boolean_value(9F)
nvlist_lookup_nvlist_array(9F)
nvlist_lookup_string_array(9F)
nvlist_lookup_uint16_array(9F)
nvlist_lookup_uint32_array(9F)
nvlist_lookup_uint64_array(9F)
nvpair_value_boolean_array(9F)
pci_plist_lookup_int16_array(9F)
pci_plist_lookup_int32_array(9F)
pci_plist_lookup_int64_array(9F)
pci_plist_lookup_int8_array(9F)
pci_plist_lookup_string_array(9F)
pci_plist_lookup_uint16_array(9F)
pci_plist_lookup_uint32_array(9F)
pci_plist_lookup_uint64_array(9F)
pci_plist_lookup_uint8_array(9F)
scsi_get_device_type_scsi_options(9F)
scsi_get_device_type_string(9F)
scsi_sense_cmdspecific_uint64(9F)
usb_get_current_frame_number(9F)
usb_get_max_pkts_per_isoc_request(9F)
usb_pipe_get_max_bulk_transfer_size(9F)
usb_pipe_stop_intr_polling(9F)
usb_pipe_stop_isoc_polling(9F)
- initialize DDI entry points for an audio device driver
#include <sys/audio/audio_driver.h> void audio_init_ops(struct dev_ops *devops, const char *name);
void audio_fini_ops(struct dev_ops *devops);
pointer to the dev_ops(9S) vector for the device instance
name of the audio driver, which must be the same as the kernel module name. For example, “audiohd”.
Solaris DDI specific (Solaris DDI)
The audio_init_ops() function initializes the device operations vector for an audio driver, setting a number of entry points to common implementation from the audio framework. It must be executed during the _init(9E) function for the driver.
The actual values supplied by audio_init_ops() are the fields for devo_cb_ops and devo_getinfo.
Device drivers need to supply any other entry points, especially the attach(9E), detach(9E), and quiesce(9E) entry points.
The ddi_driver_name(9F) function cannot be used to determine the device driver's name, as there is not necessarily a dev_info_t to use during the _init(9E) entry point. A constant string must be supplied by the driver.
The audio_fini_ops() function undoes the work of audio_init_ops() and releases resources allocated by audio_init_ops().
These functions may be called from the driver's _init(9E) and _fini(9E) entry points only.
See attributes(5) for descriptions of the following attributes:
|
attributes(5), attach(9E), detach(9E), _fini(9E), _init(9E), quiesce(9E), ddi_driver_name(9F), dev_ops(9S)
Audio device driver names are limited to at most 12 characters.
The audio DDI is provided by the drv/audio module. Developers should supply “-dy -Ndrv/audio” on the final link command line to ensure that symbol dependencies can be satisfied when the driver is loaded.