Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library |
csx_AccessConfigurationRegister(9F)
csx_Parse_CISTPL_BYTEORDER(9F)
csx_Parse_CISTPL_CFTABLE_ENTRY(9F)
csx_Parse_CISTPL_DEVICEGEO(9F)
csx_Parse_CISTPL_DEVICEGEO_A(9F)
csx_Parse_CISTPL_DEVICE_OA(9F)
csx_Parse_CISTPL_DEVICE_OC(9F)
csx_Parse_CISTPL_LINKTARGET(9F)
csx_Parse_CISTPL_LONGLINK_A(9F)
csx_Parse_CISTPL_LONGLINK_C(9F)
csx_Parse_CISTPL_LONGLINK_MFC(9F)
ddi_get_soft_iblock_cookie(9F)
ddi_intr_get_supported_types(9F)
ddi_prop_lookup_byte_array(9F)
ddi_prop_lookup_int64_array(9F)
ddi_prop_lookup_string_array(9F)
ddi_prop_update_byte_array(9F)
ddi_prop_update_int64_array(9F)
ddi_prop_update_string_array(9F)
ldi_prop_lookup_byte_array(9F)
ldi_prop_lookup_int64_array(9F)
ldi_prop_lookup_string_array(9F)
mac_prop_info_set_default_link_flowctrl(9F)
mac_prop_info_set_default_str(9F)
mac_prop_info_set_default_uint8(9F)
mac_prop_info_set_range_uint32(9F)
net_event_notify_unregister(9F)
net_instance_notify_register(9F)
net_instance_notify_unregister(9F)
net_instance_protocol_unregister(9F)
net_protocol_notify_register(9F)
nvlist_lookup_boolean_array(9F)
nvlist_lookup_boolean_value(9F)
nvlist_lookup_nvlist_array(9F)
nvlist_lookup_string_array(9F)
nvlist_lookup_uint16_array(9F)
nvlist_lookup_uint32_array(9F)
nvlist_lookup_uint64_array(9F)
nvpair_value_boolean_array(9F)
pci_plist_lookup_int16_array(9F)
pci_plist_lookup_int32_array(9F)
pci_plist_lookup_int64_array(9F)
pci_plist_lookup_int8_array(9F)
pci_plist_lookup_string_array(9F)
pci_plist_lookup_uint16_array(9F)
pci_plist_lookup_uint32_array(9F)
pci_plist_lookup_uint64_array(9F)
pci_plist_lookup_uint8_array(9F)
scsi_get_device_type_scsi_options(9F)
scsi_get_device_type_string(9F)
scsi_sense_cmdspecific_uint64(9F)
usb_get_current_frame_number(9F)
usb_get_max_pkts_per_isoc_request(9F)
usb_pipe_get_max_bulk_transfer_size(9F)
usb_pipe_stop_intr_polling(9F)
usb_pipe_stop_isoc_polling(9F)
- parse Function Extension tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_FUNCE(client_handle_t ch, tuple_t *tu, cistpl_funce_t *cf, uint32_t fid);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F).
Pointer to a cistpl_funce_t structure which contains the parsed CISTPL_FUNCE tuple information upon return from this function.
The function ID code to which this CISTPL_FUNCE tuple refers. See csx_Parse_CISTPL_FUNCID(9F).
This function parses the Function Extension tuple, CISTPL_FUNCE, into a form usable by PC Card drivers.
The CISTPL_FUNCE tuple is used to describe information about a specific PCCard function. The information provided is determined by the Function Identification tuple, CISTPL_FUNCID, that is being extended. Each function has a defined set of extension tuples.
The structure members of cistpl_funce_t are:
uint32_t function; /* type of extended data */ uint32_t subfunction; union { struct serial { uint32_t ua; /* UART in use */ uint32_t uc; /* UART capabilities */ } serial; struct modem { uint32_t fc; /* supported flow control methods */ uint32_t cb; /* size of DCE command buffer */ uint32_t eb; /* size of DCE to DCE buffer */ uint32_t tb; /* size of DTE to DCE buffer */ } modem; struct data_modem { uint32_t ud; /* highest data rate */ uint32_t ms; /* modulation standards */ uint32_t em; /* err correct proto and /* non-CCITT modulation */ uint32_t dc; /* data compression protocols */ uint32_t cm; /* command protocols */ uint32_t ex; /* escape mechanisms */ uint32_t dy; /* standardized data encryption */ uint32_t ef; /* miscellaneous end user features */ uint32_t ncd; /* number of country codes */ uchar_t cd[16]; /* CCITT country code */ } data_modem; struct fax { uint32_t uf; /* highest data rate in DTE/UART */ uint32_t fm; /* CCITT modulation standards */ uint32_t fy; /* standardized data encryption */ uint32_t fs; /* feature selection */ uint32_t ncf; /* number of country codes */ uchar_t cf[16]; /* CCITT country codes */ } fax; struct voice { uint32_t uv; /* highest data rate */ uint32_t nsr; uint32_t sr[16]; /* voice sampling rates (*100) */ uint32_t nss; uint32_t ss[16]; /* voice sample sizes (*10) */ uint32_t nsc; uint32_t sc[16]; /* voice compression methods */ } voice; struct lan { uint32_t tech; /* network technology */ uint32_t speed; /* media bit or baud rate */ uint32_t media; /* network media supported */ uint32_t con; /* open/closed connector standard */ uint32_t id_sz; /* length of lan station id */ uchar_t id[16]; /* station ID */ } lan; } data;
The fields are defined as follows:
This field identifies the type of extended information provided about a function by the CISTPL_FUNCE tuple. This field is defined as follows:
Serial port interface
Common modem interface
Data modem services
Fax modem services
Voice services
Capabilities of the data modem interface
Capabilities of the fax modem interface
Capabilities of the voice modem interface
Serial port interface for data modem services
Serial port interface for fax modem services
Serial port interface for voice modem services
This is for identifying a sub-category of services provided by a function in the CISTPL_FUNCE tuple. The numeric value of the code is in the range of 1 to 15.
This is the serial port UART identification and is defined as follows:
Intel 8250
NS 16450
NS 16550
This identifies the serial port UART capabilities and is defined as follows:
Space parity supported
Mark parity supported
Odd parity supported
Even parity supported
5 bit characters supported
6 bit characters supported
7 bit characters supported
8 bit characters supported
1 stop bit supported
1.5 stop bits supported
2 stop bits supported
This identifies the modem flow control methods and is defined as follows:
Transmit XON/XOFF
Receiver XON/XOFF
Transmit hardware flow control (CTS)
Receiver hardware flow control (RTS)
Transparent flow control
This identifies the modem modulation standards and is defined as follows:
300bps
300bps (V.21)
600/1200bps (V.23)
1200bps (V.22A V.22B)
2400bps (US Bell 212
2400bps (V.22bis)
2400bps leased line (V.26)
2400bps (V.26bis)
4800/2400bps leased line (V.27bis)
9600/7200/4800 leased line (V.29)
Up to 9600bps (V.32)
Up to 14400bps (V.32bis)
Up to 28800 V.FAST
This identifies modem error correction/detection protocols and is defined as follows:
MNP levels 2-4
CCITT LAPM (V.42)
This identifies modem data compression protocols and is defined as follows:
CCITT compression V.42
MNP compression (uses MNP 2, 3 or 4)
This identifies modem command protocols and is defined as follows:
ANSI/EIA/TIA 602 “Action” commands
ANSI/EIA/TIA 602 “ACE/DCE IF Params”
ANSI/EIA/TIA 602 “Ace Parameters”
MNP specification AT commands
V.25bis calling commands
V.25bis test procedures
DMCL command mode
This identifies the modem escape mechanism and is defined as follows:
BREAK support standardized
+++ returns to command mode
User defined escape character
This identifies modem standardized data encryption and is a reserved field for future use and must be set to 0.
This identifies modem miscellaneous features and is defined as follows:
Caller ID is supported
This identifies fax modulation standards and is defined as follows:
300bps (V.21-C2)
4800/2400bps (V.27ter)
9600/7200/4800 leased line (V.29)
14.4K/12K/9600/7200bps (V.17)
4.4K/12K/9600/7200 leased line (V.33)
This identifies the fax feature selection and is defined as follows:
Group 2 (T.3) service class
Group 3 (T.4) service class
Group 4 (T.6) service class
Error Correction Mode
Voice requests allowed
Polling support
File transfer support
Password support
This identifies the LAN technology type and is defined as follows:
Arcnet
Ethernet
Token Ring
Local Talk
FDDI/CDDI
ATM
Wireless
This identifies the LAN media type and is defined as follows:
Generic interface
Unshielded twisted pair
Shielded twisted pair
Thin coax
Thick coax
Fiber
Spread spectrum radio 902-928 MHz
Spread spectrum radio 2.4 GHz
Spread spectrum radio 5.4 GHz
Diffuse infra red
Point to point infra red
Successful operation.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_Parse_CISTPL_FUNCID(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S)
PC Card 95 Standard, PCMCIA/JEIDA