Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library |
csx_AccessConfigurationRegister(9F)
csx_Parse_CISTPL_BYTEORDER(9F)
csx_Parse_CISTPL_CFTABLE_ENTRY(9F)
csx_Parse_CISTPL_DEVICEGEO(9F)
csx_Parse_CISTPL_DEVICEGEO_A(9F)
csx_Parse_CISTPL_DEVICE_OA(9F)
csx_Parse_CISTPL_DEVICE_OC(9F)
csx_Parse_CISTPL_LINKTARGET(9F)
csx_Parse_CISTPL_LONGLINK_A(9F)
csx_Parse_CISTPL_LONGLINK_C(9F)
csx_Parse_CISTPL_LONGLINK_MFC(9F)
ddi_get_soft_iblock_cookie(9F)
ddi_intr_get_supported_types(9F)
ddi_prop_lookup_byte_array(9F)
ddi_prop_lookup_int64_array(9F)
ddi_prop_lookup_string_array(9F)
ddi_prop_update_byte_array(9F)
ddi_prop_update_int64_array(9F)
ddi_prop_update_string_array(9F)
ldi_prop_lookup_byte_array(9F)
ldi_prop_lookup_int64_array(9F)
ldi_prop_lookup_string_array(9F)
mac_prop_info_set_default_link_flowctrl(9F)
mac_prop_info_set_default_str(9F)
mac_prop_info_set_default_uint8(9F)
mac_prop_info_set_range_uint32(9F)
net_event_notify_unregister(9F)
net_instance_notify_register(9F)
net_instance_notify_unregister(9F)
net_instance_protocol_unregister(9F)
net_protocol_notify_register(9F)
nvlist_lookup_boolean_array(9F)
nvlist_lookup_boolean_value(9F)
nvlist_lookup_nvlist_array(9F)
nvlist_lookup_string_array(9F)
nvlist_lookup_uint16_array(9F)
nvlist_lookup_uint32_array(9F)
nvlist_lookup_uint64_array(9F)
nvpair_value_boolean_array(9F)
pci_plist_lookup_int16_array(9F)
pci_plist_lookup_int32_array(9F)
pci_plist_lookup_int64_array(9F)
pci_plist_lookup_int8_array(9F)
pci_plist_lookup_string_array(9F)
pci_plist_lookup_uint16_array(9F)
pci_plist_lookup_uint32_array(9F)
pci_plist_lookup_uint64_array(9F)
pci_plist_lookup_uint8_array(9F)
scsi_get_device_type_scsi_options(9F)
scsi_get_device_type_string(9F)
scsi_sense_cmdspecific_uint64(9F)
usb_get_current_frame_number(9F)
usb_get_max_pkts_per_isoc_request(9F)
usb_pipe_get_max_bulk_transfer_size(9F)
usb_pipe_stop_intr_polling(9F)
usb_pipe_stop_isoc_polling(9F)
- set driver memory mapping parameters
#include <sys/ddi.h> #include <sys/sunddi.h> int devmap_devmem_setup(devmap_cookie_t dhp, dev_info_t *dip, struct devmap_callback_ctl *callbackops, uint_t rnumber, offset_t roff, size_t len, uint_t maxprot, uint_t flags, ddi_device_acc_attr_t *accattrp);
int devmap_umem_setup(devmap_cookie_t dhp, dev_info_t *dip, struct devmap_callback_ctl *callbackops, ddi_umem_cookie_t cookie, offset_t koff, size_t len, uint_t maxprot, uint_t flags, ddi_device_acc_attr_t *accattrp);
Solaris DDI specific (Solaris DDI).
devmap_devmem_setup() parameters:
An opaque mapping handle that the system uses to describe the mapping.
Pointer to the device's dev_info structure.
Pointer to a devmap_callback_ctl(9S) structure. The structure contains pointers to device driver-supplied functions that manage events on the device mapping. The framework will copy the structure to the system private memory.
Index number to the register address space set.
Offset into the register address space.
Length (in bytes) of the mapping to be mapped.
Maximum protection flag possible for attempted mapping. Some combinations of possible settings are:
Read access is allowed.
Write access is allowed.
Execute access is allowed.
User-level access is allowed. The mapping is done as a result of a mmap(2) system call.
All access is allowed.
Used to determine the cache attribute.
Possible values of the cache attribute are:
The CPU can cache the data it fetches and push it to memory at a later time. This is the default attribute that is used if no cache attributes are specified.
The CPU never caches the data, but writes can occur out of order or can be combined. Reordering is implied.
If IOMEM_DATA_UC_WR_COMBINE is specified but not supported, IOMEM_DATA_UNCACHED is used instead.
The CPU never caches data, but has uncacheable access to memory. Strict ordering is implied.
The cache attributes are mutually exclusive. Any combination of the values leads to a failure. On the SPARC architecture, only IOMEM_DATA_CACHED is meaningful. Others lead to a failure.
Pointer to a ddi_device_acc_attr() structure of the device. See ddi_device_acc_attr(9S). The value in devacc_attr_dataorder is ignored in the current release. The value in devacc_attr_endian_flags is meaningful on the SPARC architecture only.
devmap_umem_setup() parameters:
An opaque data structure that the system uses to describe the mapping.
Pointer to the device's dev_info structure.
Pointer to a devmap_callback_ctl(9S) structure. The structure contains pointers to device driver-supplied functions that manage events on the device mapping.
A kernel memory cookie (see ddi_umem_alloc(9F)).
Offset into the kernel memory defined by cookie.
Length (in bytes) of the mapping to be mapped.
Maximum protection flag possible for attempted mapping. Some combinations of possible settings are:
Read access is allowed.
Write access is allowed.
Execute access is allowed.
User-level access is allowed (the mapping is being done as a result of a mmap(2) system call).
All access is allowed.
Must be set to 0.
Pointer to a ddi_device_acc_attr(9S) structure. Ignored in the current release. Reserved for future use.
The devmap_devmem_setup() and devmap_umem_setup() functions are used in the devmap(9E) entry point to pass mapping parameters from the driver to the system.
The dhp argument specifies a device mapping handle that the system uses to store all mapping parameters of a physical contiguous memory. The system copies the data pointed to by callbackops to a system private memory. This allows the driver to free the data after returning from either devmap_devmem_setup() or devmap_umem_setup(). The driver is notified of user events on the mappings via the entry points defined by devmap_callback_ctl(9S). The driver is notified of the following user events:
User has called mmap(2) to create a mapping to the device memory.
User has accessed an address in the mapping that has no translations.
User has duplicated the mapping. Mappings are duplicated when the process calls fork(2).
User has called munmap(2) on the mapping or is exiting, exit(2).
See devmap_map(9E), devmap_access(9E), devmap_dup(9E), and devmap_unmap(9E) for details on these entry points.
By specifying a valid callbackops to the system, device drivers can manage events on a device mapping. For example, the devmap_access(9E) entry point allows the drivers to perform context switching by unloading the mappings of other processes and to load the mapping of the calling process. Device drivers may specify NULL to callbackops which means the drivers do not want to be notified by the system.
The maximum protection allowed for the mapping is specified in maxprot. accattrp defines the device access attributes. See ddi_device_acc_attr(9S) for more details.
devmap_devmem_setup() is used for device memory to map in the register set given by rnumber and the offset into the register address space given by roff. The system uses rnumber and roff to go up the device tree to get the physical address that corresponds to roff. The range to be affected is defined by len and roff. The range from roff to roff + len must be a physical contiguous memory and page aligned.
Drivers use devmap_umem_setup() for kernel memory to map in the kernel memory described by cookie and the offset into the kernel memory space given by koff. cookie is a kernel memory pointer obtained from ddi_umem_alloc(9F). If cookie is NULL, devmap_umem_setup() returns -1. The range to be affected is defined by len and koff. The range from koff to koff + len must be within the limits of the kernel memory described by koff + len and must be page aligned.
Drivers use devmap_umem_setup() to export the kernel memory allocated by ddi_umem_alloc(9F) to user space. The system selects a user virtual address that is aligned with the kernel virtual address being mapped to avoid cache incoherence if the mapping is not MAP_FIXED.
Successful completion.
An error occurred.
devmap_devmem_setup() and devmap_umem_setup() can be called from user, kernel, and interrupt context.
exit(2), fork(2), mmap(2), munmap(2), devmap(9E), ddi_umem_alloc(9F), ddi_device_acc_attr(9S), devmap_callback_ctl(9S)