Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11.1 Information Library |
csx_AccessConfigurationRegister(9F)
csx_Parse_CISTPL_BYTEORDER(9F)
csx_Parse_CISTPL_CFTABLE_ENTRY(9F)
csx_Parse_CISTPL_DEVICEGEO(9F)
csx_Parse_CISTPL_DEVICEGEO_A(9F)
csx_Parse_CISTPL_DEVICE_OA(9F)
csx_Parse_CISTPL_DEVICE_OC(9F)
csx_Parse_CISTPL_LINKTARGET(9F)
csx_Parse_CISTPL_LONGLINK_A(9F)
csx_Parse_CISTPL_LONGLINK_C(9F)
csx_Parse_CISTPL_LONGLINK_MFC(9F)
ddi_get_soft_iblock_cookie(9F)
ddi_intr_get_supported_types(9F)
ddi_prop_lookup_byte_array(9F)
ddi_prop_lookup_int64_array(9F)
ddi_prop_lookup_string_array(9F)
ddi_prop_update_byte_array(9F)
ddi_prop_update_int64_array(9F)
ddi_prop_update_string_array(9F)
ldi_prop_lookup_byte_array(9F)
ldi_prop_lookup_int64_array(9F)
ldi_prop_lookup_string_array(9F)
mac_prop_info_set_default_link_flowctrl(9F)
mac_prop_info_set_default_str(9F)
mac_prop_info_set_default_uint8(9F)
mac_prop_info_set_range_uint32(9F)
net_event_notify_unregister(9F)
net_instance_notify_register(9F)
net_instance_notify_unregister(9F)
net_instance_protocol_unregister(9F)
net_protocol_notify_register(9F)
nvlist_lookup_boolean_array(9F)
nvlist_lookup_boolean_value(9F)
nvlist_lookup_nvlist_array(9F)
nvlist_lookup_string_array(9F)
nvlist_lookup_uint16_array(9F)
nvlist_lookup_uint32_array(9F)
nvlist_lookup_uint64_array(9F)
nvpair_value_boolean_array(9F)
pci_plist_lookup_int16_array(9F)
pci_plist_lookup_int32_array(9F)
pci_plist_lookup_int64_array(9F)
pci_plist_lookup_int8_array(9F)
pci_plist_lookup_string_array(9F)
pci_plist_lookup_uint16_array(9F)
pci_plist_lookup_uint32_array(9F)
pci_plist_lookup_uint64_array(9F)
pci_plist_lookup_uint8_array(9F)
scsi_get_device_type_scsi_options(9F)
scsi_get_device_type_string(9F)
scsi_sense_cmdspecific_uint64(9F)
usb_get_current_frame_number(9F)
usb_get_max_pkts_per_isoc_request(9F)
usb_pipe_get_max_bulk_transfer_size(9F)
usb_pipe_stop_intr_polling(9F)
usb_pipe_stop_isoc_polling(9F)
- ldi cookie management
#include <sys/sunldi.h> int ldi_ident_from_dip(dev_info_t *dip, ldi_ident_t *lip);
int ldi_ident_from_dev(dev_t dev, ldi_ident_t *lip);
int ldi_ident_from_stream(struct queue *sq, ldi_ident_t *lip);
void ldi_ident_release(ldi_ident_t li);
ldi identifier
ldi identifier pointer
pointer to device info node
device number
pointer to a stream queue
The ldi_ident_from_dev() function allocates and returns an ldi identifier that is associated with the device number specified by dev. The new ldi identifier is returned in the ldi identifier pointer parameter lip.
The ldi_ident_from_dip() function allocates and returns an ldi identifier that is associated with the device info node pointed to by dip. The new ldi identifier is returned in the ldi identifier pointer parameter lip.
The ldi_ident_from_stream() function allocates and returns an ldi identifier that is associated with the stream pointed to by queue. The new ldi identifier is returned in the ldi identifier pointer parameter lip.
The ldi_ident_release() function releases an identifier that was allocated by one of the ldi_ident_from_*() functions.
The ldi_ident_from_dev(), ldi_ident_from_dip(), and ldi_ident_from_stream() functions return 0 upon success.
All of these functions return EINVAL for invalid input parameters.
These functions can be called from user or kernel context, and ldi_ident_release() can also be called from interrupt context.