Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library |
- asynchronous I/O request structure
#include <sys/uio.h> #include <sys/aio_req.h> #include <sys/ddi.h> #include <sys/sunddi.h>
Solaris DDI specific (Solaris DDI)
An aio_req structure describes an asynchronous I/O request.
struct uio*aio_uio; /* uio structure describing the I/O request */
The aio_uio member is a pointer to a uio(9S) structure, describing the I/O transfer request.