Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library |
- linkage structure for loadable miscellaneous modules
#include <sys/modctl.h>
Solaris DDI specific (Solaris DDI).
The modlmisc structure is used by miscellaneous modules to export module specific information to the kernel.
struct mod_ops *misc_modops; char *misc_linkinfo;
Must always be initialized to the address of mod_miscops. This member identifies the module as a loadable miscellaneous module.
Can be any string up to MODMAXNAMELEN characters (including the terminating NULL characters), and is used to describe the module, but can also contain other information (such as a version number).