Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library |
- SCSI ASC ASCQ to message structure
#include <sys/scsi/scsi.h>
Solaris DDI specific (Solaris DDI).
The scsi_asc_key_strings structure stores the ASC and ASCQ codes and a pointer to the related ASCII string.
ushort_t asc; /* ASC code */ ushort_t ascq; /* ASCQ code */ char *message; /* ASCII message string */ asc Contains the ASC key code. ascq Contains the ASCQ code. message Points to the NULL terminated ASCII string describing the asc and ascq condition
ANSI Small Computer System Interface-2 (SCSI-2)