Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library |
- MAC callbacks data structure
#include <sys/mac_provider.h>
Solaris architecture specific (Solaris DDI)
The mac_callbacks data structure is used by MAC device drivers to expose their entry points to the MAC layer. A pointer to an instance of the mac_callbacks structure is passed through the m_callbacks field of the mac_register(9S) structure as part of the registration of a device driver instance through mac_register(9F).
uint_t mc_callbacks; /* Denotes which callbacks are set */ mac_getstat_t mc_getstat; /* Get the value of a statistic */ mac_start_t mc_start; /* Start the device */ mac_stop_t mc_stop; /* Stop the device */ mac_setpromisc_t mc_setpromisc; /* Enable or disable promiscuous mode */ mac_multicst_t mc_multicst; /* Enable or disable a multicast addr */ mac_unicst_t mc_unicst; /* Set the unicast MAC address */ mac_tx_t mc_tx; /* Transmit a packet */ mac_ioctl_t mc_ioctl; /* Process an unknown ioctl */ mac_getcapab_t mc_getcapab; /* Get capability information */ mac_set_prop_t mc_setprop; /* Set property value */ mac_get_prop_t mc_getprop; /* Get property value */ mac_prop_info_t mc_propinfo; /* Get property attributes */
Below are descriptions of the members of the mac_callbacks structure that are visible to the device driver.
Flags specifying which ones of the optional entry points are implemented by the driver. The following flags are supported:
Set by the driver when the mc_ioctl() entry point is present.
Set by the driver when the mc_getcapab() entry point is present.
Set by the driver when the mc_setprop() entry point is present.
Set by the driver when the mc_getprop() entry point is present.
Set by the driver when the mc_propinfo() entry point is present.
Set by a driver which implements all properties entry points (mc_setprop(), mc_getprop(), and mc_propinfo()). Setting MC_PROPERTIES is the equivalent of setting the three flags MC_SETPROP, MC_GETPROP, and MC_PROPINFO.
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
pointer to driver entry point
See mac(9E) for more information about MAC driver entry points.
See attributes(5) for descriptions of the following attributes:
|