Skip Navigation Links | |
Exit Print View | |
man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library |
- data storage structure for I/O using uio
#include <sys/uio.h>
Architecture independent level 1 (DDI/DKI).
An iovec structure describes a data storage area for transfer in a uio(9S) structure. Conceptually, it can be thought of as a base address and length specification.
caddr_t iov_base; /* base address of the data storage area */ /* represented by the iovec structure */ int iov_len; /* size of the data storage area in bytes */