Skip Navigation Links | |
Exit Print View | |
man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library |
- legacy service processor driver interfaces
#include <sys/mbc_intf.h>
open("/dev/bmc", mode);
The bmc streams driver provides access to a system's service processor using the legacy Sun BMC driver interface.
bmc uses putmsg() and getmsg() as the primary method to communicate with a system service processor. A streams message which contains a bmc_req_tstructure and response buffer is sent to the driver with putmsg(). The driver issues the request to the system service processor. The driver retrieves the response from the system BMC and puts the response in the buffer. When the user-land application issues a streams getmsg() the original request and the response from the BMC are returned.
This is the original bmc driver module. If you only need the Sun legacy bmc driver then this is the driver module that you should use.
If you want the extended features of the new OpenIPMI driver, but still require legacy bmc driver functionality you have the choice of using the new sbmc/ipmi driver module pair. This new pair offers an OpenIPMI compatible driver (ipmi) and a legacy bmc compatible driver, sbmc, both of which can be used at the same time.
You can only have the original bmc or the new pair sbmc/ipmi enabled. You can not have both enabled.
This choice is made though driver properties as follows:
Driver Module Functionality Enable Property bmc Legacy bmc driver bmc.conf/bmc-enable ipmi OpenIPMI driver ipmi.conf/ipmi-enable sbmc bmc compatibility sbmc.conf/sbmc-enable for OpenIPMI
The driver properties are set by editing the related configuration files. The configuration file for the bmc driver is bmc.conf. The configuration file for the bmc compatibility module for OpenIPMI is sbmc.conf. When the ipmi module is enabled there is a bmc compatibility mode module called sbmc and its related configuration file, sbmc.conf.
The following properties are supported:
Enables or disables the bmc driver. When the driver is disabled it does not attach and is not active.
When set to 1 the bmc driver is enabled.
Enables or disables the bmc driver. When the driver is disabled it does not attach and is not active.
When this is set to 1 the sbmc compatible driver is enabled. The default is disabled (0).
If this property is enabled then ipmi must be enabled and bmc must not be enabled.
Legacy bmc driver file node
OpenIPMI compatible driver file node
64-bit x86 kernel bmc driver module
64-bit x86 kernel bmc compatible driver module
bmc configuration file
OpenIPMI driver property configuration file
bmc compatibility module for OpenIPMI configuration file
64-bit SPARC kernel bmc driver module
64-bit SPARC kernel bmc compatible driver module
See attributes(5) for a description of the following attributes:
|