Skip Navigation Links | |
Exit Print View | |
man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library |
- Intel PRO/1000 Gigabit family of network interface controllers
/dev/e1000g
The e1000g Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), over Intel PRO/1000 family of Gigabit controllers. This driver supports multiple Intel Gigabit controllers installed within the system. The e1000g driver provides basic support including chip initialization, frame transmit and receive, multicast support, and error recovery and reporting.
The cloning, character-special device /dev/e1000g is used to access all Intel Gigabit devices installed within the system.
The e1000g driver is managed by the dladm(1M) command line utility, which allows VLANs to be defined on top of e1000g instances and for e1000g instances to be aggregated. See dladm(1M) for more details.
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are as follows:
Maximum SDU (with jumbo frame) is as high as 16298.
Minimum SDU is 0. The driver pads to the mandatory 60-octet minimum packet size.
The dlsap address length is 8.
MAC type is DL_ETHER.
The sap length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
The broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
The e1000g driver does not support the use of shared RAM on the board.
To configure the e1000g driver:
Use prtconf -v | grep pci8086,[12][01][01][0-F] to obtain the instance number of the driver.
Use ifconfig e1000ginstance plumb to plumb the controller.
Use ifconfig e1000ginstance inet ip_address netmask + broadcast + -trailers up to bring up the interface.
Use the ping(1M) command to contact interfaces on the network to verify that the configuration is operational.
The following e1000g.conf configuration options are supported:
This is a bitmap for the speeds advertised during auto-negotiation.
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 Setting| N/A | N/A | 1000F | N/A | 100F | 100H | 10F | 10H
The adapter only auto-negotiates to a speed that is advertised. For example: AutoNegAdvertised = 4 causes an adapter to only advertise auto-negotiation at 100 Mbps, full duplex. No other link speeds are accepted or given during auto-negotiation. AutoNegAdvertised=47 advertises all speeds available, This is the same as using the default setting of 0.
Allowed values
Default
Specify the speed and duplex mode for each instance.
If you set ForceSpeedDuplex=7,4, the e1000g0 is set to auto-negotiate and e1000g1 is set to 100 Mbps, full duplex. Note that fiber optic ethernet adapters ignore this setting.
Allowed values are:
10 Megabits per second, Half Duplex.
10 Megabits per second, Full Duplex.
100 Megabits per second, Half Duplex.
100 Megabits per second, Full Duplex.
Auto-negotiate speed and duplex. (Default).
Upper limit on the maximum MTU size the driver allows. All Intel gigabit adapters (except the 82542-based Intel PRO/1000 adapter) allow the configuration of jumbo frames.
For a Intel PRO/1000 adapter that is later than 82571 (including 82571) the maximum MTU accepted by the MAC is 9216. For others, the maximum MTU accepted by the MAC is 16298. Use ifconfig(1M) to configure jumbo frames. Using ifconfig with the adapter instance and the mtu argument (ifconfig e1000g0 mtu 9216) configures adapter e1000g0 for the maximum allowable jumbo frame size.
Allowed values are:
Standard ethernet frames with a MTU equal to 1500. (Default).
Jumbo frames with a maximum MTU of 4010.
Jumbo frames with a maximum MTU of 8106.
Jumbo frames with a maximum MTU of 16298.
Flow control utilizes ethernet XON and unicast and multicast XOFF packets to allow ethernet equipment to slow down the stream of data between two ethernet devices.
Allowed values are:
Disable. Packets can get dropped in high-throughput situations, leading to reduced network performance.
Receive only.
Transmit only.
Receive and transmit. (Default).
Use adapter's EEPROM-programmed factory default setting.
You must enable this feature on Intel 82543CG-based copper adapters to operate correctly with TBI mode ethernet hardware.
Allowed values are:
Disable.
Enable. (Default).
Controls the PHY master/slave setting. Manually forcing master or slave can reduce time needed to link with Planex 08TX and IO data switches. This setting should remain as the hardware default.
Allowed values are:
Hardware default. (Default).
Force master.
Force slave.
Force auto.
By default, the following configuration options are not displayed in the e1000g.conf file. Although they are configurable, you should not change these options:
Number of available receive descriptors. Multiple receive descriptors increase receive performance, but decrease available memory.
Allowed values.
Default. (MTU < 4010).
Default. (MTU >= 4010).
Number of transmit descriptors available to the driver. Multiple transmit descriptors increase transmit performance, but decrease available memory.
Allowed values.
Default. (MTU < 4010).
Default. (MTU >= 4010).
Number of pre-allocated buffers that the driver can use for received data. Pre-allocating buffers can improve receive performance but decrease available memory.
Allowed values.
Default. (MTU < 4010).
Default. (MTU >= 4010).
Number of pre-allocated buffers that the driver can use for transmit data. Pre-allocating buffers can improve transmit performance but decrease available memory.
Allowed values.
Default. (MTU < 4010).
Default. (MTU >= 4010).
Maximum number of receive packets that the driver can handle for each interrupt.
CPU utilization can be lowered through more efficient interrupt management. If this value is increased, the time needed by the CPU to process the individual interrupts increases, thereby nullifying any performance gains realized by handling less interrupts.
Allowed values.
Default.
In addition to the e1000g.conf file, you can also use the dladm(1M) command to configure the e1000g driver.
To view supported configuration parameters, do the following step:
# dladm show-linkprop e1000g0
In addition, the current settings of the parameters can be found using dladm show-ether. Using dladm(1M), you can set the link speed/duplex using the enabled capability parameters supported by the e1000g device. Each parameter contains a boolean value that determines if the device enables that mode of operation. The adv_autoneg_cap parameter controls auto-negotiation. When adv_autoneg_cap is set to 0, the driver forces the mode of operation selected by the first non-zero parameter in priority order as shown below:
en_1000fdx_cap 1000Mbps full duplex en_100fdx_cap 100Mbps full duplex en_100hdx_cap 100Mbps half duplex en_10fdx_cap 10Mbps full duplex en_10hdx_cap 10Mbps half duplex
Note - The link mode of 1000Mbps half duplex is not supported.
Forced link mode of 1000Mbps full duplex is not supported.
Setting all the enabled link capabilities to 0 results in the link being reset to auto-negotiation with full link capabilities advertised.
1 10Mbps half duplex 2 10Mbps full duplex 3 100Mbps half duplex 4 100Mbps full duplex
Character special device.
Driver configuration file.
64–bit driver binary (SPARC).
64–bit driver binary. (x86).
See attributes(5) for descriptions of the following attributes:
|
dladm(1M), ifconfig(1M), kstat(1M), ping(1M), attributes(5), dlpi(7P)
Intel PRO/1000 Gigabit Adapter Driver Installation Notes for Solaris
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Guide