Skip Navigation Links | |
Exit Print View | |
man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library |
- Class II logical link control driver
The llc2 logical link control driver interfaces network software (NetBIOS, SNA, OSI, and so on) running under the Solaris operating environment to a physical LAN network controlled by one of the supported communications adapters. The llc2 driver, which appears as a STREAMS driver to the network software, resides in the kernel and is accessed by standard UNIX STREAMS functions.
This version of the llc2 driver includes support for both connectionless and connection-oriented logical link control class II (llc2) operations for Ethernet, Token Ring, and FDDI adapters when accessed through the appropriate Solaris MAC layer driver. The Data Link Provider Interface (DLPI) to the llc2 driver enables multiple and different protocol stacks, (including NetBIOS and SNA), to operate simultaneously over one or more local area networks.
To start the llc2 driver by default, rename file /etc/llc2/llc2_start.default to /etc/llc2/llc2_start. This allows the /etc/rc2.d/S40llc2 script to build up the configuration file for each ppa interface in /etc/llc2/default/llc2.* and start llc2 on each interface. To verify the configuration files, manually run /usr/lib/llc2/llc2_autoconfig.
For more information on the llc2 driver, see the IEEE standard 802.2 Logical Link Control.
You can obtain LLC2 statistics or reset the statistics counter to zero using the ILD_LLC2 ioctl. The ILD_LLC2 ioctl has a number of subcommands. The following retrieve LLC2 statistics:
|
The structure used depends on the subcommand sent.
The LLC2_GET_STA_STATS command retrieves statistics on a particular Physical Point of Attachment (PPA).
When sending the LLC2_GET_STA_STATS command, the llc2GetStaStats structure is used:
typedef struct llc2GetStaStats { uint_t ppa; uint_t cmd; uchar_t clearFlag; uchar_t state; ushort_t numSaps; uchar_t saps[LLC2_MAX_SAPS]; uint_t nullSapXidCmdRcvd; uint_t nullSapXidRspSent; uint_t nullSapTestCmdRcvd; uint_t nullSapTestRspSent; uint_t outOfState; uint_t allocFail; uint_t protocolError; } llc2GetStaStats_t;
The members of the structure are:
|
The LLC2_GET_SAP_STATS command retrieves statistics related to a particular SAP. When sending the LLC2_GET_SAP_STATS command, the llc2GetSapStats structure is used:
typedef struct llc2GetSapStats { uint_t ppa; uint_t cmd; uchar_t sap; uchar_t clearFlag; uchar_t state; uint_t numCons; ushort_t cons[LLC2_MAX_CONS]; uint_t xidCmdSent; uint_t xidCmdRcvd; uint_t xidRspSent; uint_t xidRspRcvd; uint_t testCmdSent; uint_t testCmdRcvd; uint_t testRspSent; uint_t testRspRcvd; uint_t uiSent; uint_t uiRcvd; uint_t outOfState; uint_t allocFail; uint_t protocolError; } llc2GetSapStats_t;
The members are:
|
The LLC2_GET_CON_STATS command retrieves statistics related to a particular connection component. When sending the LLC2_GET_CON_STATS command, the llc2GetConStats structure is used:
typedef struct llc2GetConStats { uint_t ppa; uint_t cmd; uchar_t sap; ushort_t con; uchar_t clearFlag; uchar_t stateOldest; uchar_t stateOlder; uchar_t stateOld; uchar_t state; ushort_t sid; dlsap_t rem; ushort_t flag; uchar_t dataFlag; uchar_t k; uchar_t vs; uchar_t vr; uchar_t nrRcvd; ushort_t retryCount; uint_t numToBeAcked; uint_t numToResend; uint_t macOutSave; uint_t macOutDump; uchar_t timerOn; uint_t iSent; uint_t iRcvd; uint_t frmrSent; uint_t frmrRcvd; uint_t rrSent; uint_t rrRcvd; uint_t rnrSent; uint_t rnrRcvd; uint_t rejSent; uint_t rejRcvd; uint_t sabmeSent; uint_t sabmeRcvd; uint_t uaSent; uint_t uaRcvd; uint_t discSent; uint_t outOfState; uint_t allocFail; uint_t protocolError; uint_t localBusy; uint_t remoteBusy; uint_t maxRetryFail; uint_t ackTimerExp; uint_t pollTimerExp; uint_t rejTimerExp; uint_t remBusyTimerExp; uint_t inactTimerExp; uint_t sendAckTimerExp; } llc2GetConStats_t;
The members of the structure are:
|
See attributes(5) for a description of the following attribute:
|