Skip Navigation Links | |
Exit Print View | |
man pages section 7: Device and Network Interfaces Oracle Solaris 11.1 Information Library |
- loopback transport providers
#include <sys/ticlts.h>
#include <sys/ticots.h>
#include <sys/ticotsord.h>
The devices known as ticlts, ticots, and ticotsord are ``loopback transport providers,'' that is, stand-alone networks at the transport level. Loopback transport providers are transport providers in every sense except one: only one host (the local machine) is ``connected to'' a loopback network. Loopback transports present a TPI (STREAMS-level) interface to application processes and are intended to be accessed via the TLI (application-level) interface. They are implemented as clone devices and support address spaces consisting of ``flex-addresses,'' that is, arbitrary sequences of octets of length > 0, represented by a netbuf structure.
ticlts is a datagram-mode transport provider. It offers (connectionless) service of type T_CLTS. Its default address size is TCL_DEFAULTADDRSZ. ticlts prints the following error messages (see t_rcvuderr(3NSL)):
bad address specification
bad option specification
bound
peer in wrong state
ticots is a virtual circuit-mode transport provider. It offers (connection-oriented) service of type T_COTS. Its default address size is TCO_DEFAULTADDRSZ. ticots prints the following disconnect messages (see t_rcvdis(3NSL)):
no listener on destination address
peer has no room on connect queue
peer in wrong state
peer-initiated disconnect
provider-initiated disconnect
ticotsord is a virtual circuit-mode transport provider, offering service of type T_COTS_ORD (connection-oriented service with orderly release). Its default address size is TCOO_DEFAULTADDRSZ. ticotsord prints the following disconnect messages (see t_rcvdis(3NSL)):
no listener on destination address
peer has no room on connect queue
peer in wrong state
provider-initiated disconnect
peer-initiated disconnect
Loopback transports support a local IPC mechanism through the TLI interface. Applications implemented in a transport provider-independent manner on a client-server model using this IPC are transparently transportable to networked environments.
Transport provider-independent applications must not include the headers listed in the synopsis section above. In particular, the options are (like all transport provider options) provider dependent.
ticlts and ticots support the same service types (T_CLTS and T_COTS) supported by the OSI transport-level model.
ticotsord supports the same service type (T_COTSORD) supported by the TCP/IP model.
/dev/ticlts
/dev/ticots
/dev/ticotsord